summary refs log tree commit diff
path: root/gnu/packages/patches/emacs-kv-fix-tests.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-15 11:29:02 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-15 11:43:21 -0400
commit4920f6e634eeecb37b501bdc024dfe0aab849ed0 (patch)
treec7dd5859715071cb602133b67449a29488027f70 /gnu/packages/patches/emacs-kv-fix-tests.patch
parent513091dbd2eeba138b558f5f9bb1ee6e68eee01d (diff)
parent3d297a0017210f1dd135592efb10846840a8af88 (diff)
downloadguix-4920f6e634eeecb37b501bdc024dfe0aab849ed0.tar.gz
Merge branch 'staging' into core-updates
Conflicts resolved in:
	gnu/local.mk
	gnu/packages/cmake.scm
	gnu/packages/glib.scm
	gnu/packages/gnome.scm
	gnu/packages/gtk.scm
	gnu/packages/sdl.scm

pango-next, vala-next and librsvg-bootstrap were removed in the process.
Diffstat (limited to 'gnu/packages/patches/emacs-kv-fix-tests.patch')
-rw-r--r--gnu/packages/patches/emacs-kv-fix-tests.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-kv-fix-tests.patch b/gnu/packages/patches/emacs-kv-fix-tests.patch
new file mode 100644
index 0000000000..35a6bf004c
--- /dev/null
+++ b/gnu/packages/patches/emacs-kv-fix-tests.patch
@@ -0,0 +1,30 @@
+From 4702849bfe7462fb6c6303786dac1b670c8f0f8f Mon Sep 17 00:00:00 2001
+From: Andrew Tropin <andrew@trop.in>
+Date: Wed, 14 Sep 2022 09:17:31 +0300
+Subject: [PATCH] remove copypasted kvaq test
+
+---
+ kv-tests.el | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/kv-tests.el b/kv-tests.el
+index 1713e5e..abd6a24 100644
+--- a/kv-tests.el
++++ b/kv-tests.el
+@@ -105,13 +105,6 @@
+   (should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
+   (should-not (kvaq "b" '((:a . :b)("a" . "b")))))
+ 
+-(ert-deftest kvaq ()
+-  "Test the simple assq."
+-  (should (equal :b (kvaq :a '((:a . :b)("a" . "b")))))
+-  (should (equal 2 (kvaq 1 '((1 . 2)("a" . "b")))))
+-  (should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
+-  (should-not (kvaq "b" '((:a . :b)("a" . "b")))))
+-
+ (ert-deftest kvaqc ()
+   "Test the simple assq."
+   (should (equal :b (kvaqc :a '((:a . :b)("a" . "b")))))
+-- 
+2.37.3
+