summary refs log tree commit diff
path: root/gnu/packages/patches/findutils-test-xargs.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-01 00:55:24 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-01 01:05:06 +0100
commite80d2555f5dfa89cd44b261ead2c5fd397a51f56 (patch)
tree18b83812656d1f931150f107402a112b036f50a8 /gnu/packages/patches/findutils-test-xargs.patch
parent7165a91c7dc59561d4c4f338102f32fdab1486a6 (diff)
downloadguix-e80d2555f5dfa89cd44b261ead2c5fd397a51f56.tar.gz
gnu: findutils: Update to 4.6.0.
* gnu/packages/patches/findutils-absolute-paths.patch: Remove.
* gnu/packages/patches/findutils-test-xargs.patch: New file.
* gnu-system.am (dist_patch_DATA): Adjust accordingly.
* gnu/packages/base.scm (findutils): Update to 4.6.0.  Remove
'findutils-absolute-paths.patch' and add 'findutils-test-xargs.patch'.
Diffstat (limited to 'gnu/packages/patches/findutils-test-xargs.patch')
-rw-r--r--gnu/packages/patches/findutils-test-xargs.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/patches/findutils-test-xargs.patch b/gnu/packages/patches/findutils-test-xargs.patch
new file mode 100644
index 0000000000..10c7bed28d
--- /dev/null
+++ b/gnu/packages/patches/findutils-test-xargs.patch
@@ -0,0 +1,22 @@
+This test relies on 'xargs' being available in $PATH, which is not
+the case when we build the initial Findutils doing bootstrapping.
+Reported at <https://savannah.gnu.org/bugs/index.php?46786>.
+
+--- findutils-4.6.0/find/testsuite/sv-34976-execdir-fd-leak.sh	2015-12-31 19:37:59.401526288 +0100
++++ findutils-4.6.0/find/testsuite/sv-34976-execdir-fd-leak.sh	2015-12-31 19:38:36.061770693 +0100
+@@ -50,13 +50,14 @@ die() {
+ # Create test files, each 98 in the directories ".", "one" and "two".
+ make_test_data() {
+   d="$1"
++  xargs="`cd ../../xargs; pwd -P`/xargs"
+   (
+     cd "$1" || exit 1
+     mkdir one two || exit 1
+     for i in ${three_to_hundred} ; do
+       printf "./%03d one/%03d two/%03d " $i $i $i
+     done \
+-      | xargs touch || exit 1
++      | "$xargs" touch || exit 1
+   ) \
+   || die "failed to set up the test in ${outdir}"
+ }