summary refs log tree commit diff
path: root/gnu/packages/patches/gawk-shell.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-04-05 17:07:43 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-04-05 17:07:43 +0200
commit44e3e431cdc5c6fa619dc691747042f235e9af8a (patch)
tree4178c2dda312dd39101c7136b0ff7b34655a304d /gnu/packages/patches/gawk-shell.patch
parentbce2206021a4b929ea479a6d1c53771b8a709e90 (diff)
downloadguix-44e3e431cdc5c6fa619dc691747042f235e9af8a.tar.gz
gnu: make-bootstrap: Adjust gawk patch to 4.2.1.
* gnu/packages/patches/gawk-shell.patch: Update for 4.2.1.
Diffstat (limited to 'gnu/packages/patches/gawk-shell.patch')
-rw-r--r--gnu/packages/patches/gawk-shell.patch30
1 files changed, 19 insertions, 11 deletions
diff --git a/gnu/packages/patches/gawk-shell.patch b/gnu/packages/patches/gawk-shell.patch
index 80e9c65475..46ca5e451f 100644
--- a/gnu/packages/patches/gawk-shell.patch
+++ b/gnu/packages/patches/gawk-shell.patch
@@ -4,31 +4,39 @@ absolute file name of `sh'.
 
 --- gawk-4.1.3/io.c	2015-05-19 15:37:20.000000000 +0200
 +++ gawk-4.1.3/io.c	2015-06-09 18:39:36.918414881 +0200
-@@ -1945,7 +1945,7 @@ two_way_open(const char *str, struct red
+@@ -2025,7 +2025,7 @@
  
- 			signal(SIGPIPE, SIG_DFL);
+ 		set_sigpipe_to_default();
  
--			execl("/bin/sh", "sh", "-c", str, NULL);
-+			execlp("sh", "sh", "-c", str, NULL);
- 			_exit(errno == ENOENT ? 127 : 126);
+-		execl("/bin/sh", "sh", "-c", command, NULL);
++		execlp("sh", "sh", "-c", command, NULL);
+ 		_exit(errno == ENOENT ? 127 : 126);
+ 
+ 	case -1:
+@@ -2077,7 +2077,7 @@
  
- 		case -1:
-@@ -2129,7 +2129,7 @@ use_pipes:
+ 		signal(SIGPIPE, SIG_DFL);
+ 
+-		execl("/bin/sh", "sh", "-c", command, NULL);
++		execlp("sh", "sh", "-c", command, NULL);
+ 		_exit(errno == ENOENT ? 127 : 126);
+ 
+ 	case -1:
+@@ -2422,7 +2422,7 @@
  			fatal(_("close of pipe failed (%s)"), strerror(errno));
  		/* stderr does NOT get dup'ed onto child's stdout */
- 		signal(SIGPIPE, SIG_DFL);
+ 		set_sigpipe_to_default();
 -		execl("/bin/sh", "sh", "-c", str, NULL);
 +		execlp("sh", "sh", "-c", str, NULL);
  		_exit(errno == ENOENT ? 127 : 126);
  	}
  #endif /* NOT __EMX__, NOT __MINGW32__ */
-@@ -2323,7 +2323,7 @@ gawk_popen(const char *cmd, struct redir
+@@ -2659,7 +2659,7 @@
  		if (close(p[0]) == -1 || close(p[1]) == -1)
  			fatal(_("close of pipe failed (%s)"), strerror(errno));
- 		signal(SIGPIPE, SIG_DFL);
+ 		set_sigpipe_to_default();
 -		execl("/bin/sh", "sh", "-c", cmd, NULL);
 +		execlp("sh", "sh", "-c", cmd, NULL);
  		_exit(errno == ENOENT ? 127 : 126);
  	}
  #endif /* NOT __EMX__, NOT __MINGW32__ */
-