summary refs log tree commit diff
path: root/gnu/packages/patches/gd-fix-test-on-i686.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-07-29 14:18:07 -0400
committerMark H Weaver <mhw@netris.org>2016-07-29 14:18:07 -0400
commit0bab3af0786ffd4caec05a29d7281ac5e5c18b6b (patch)
treed83fd52d0cb72b3a9c21642583d804c8c1865646 /gnu/packages/patches/gd-fix-test-on-i686.patch
parent49d725a108dc33f4eb72faff7cf138c5dd8c64f4 (diff)
parent682a7d23385f709a680049a823bb84e45c922b3c (diff)
downloadguix-0bab3af0786ffd4caec05a29d7281ac5e5c18b6b.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/gd-fix-test-on-i686.patch')
-rw-r--r--gnu/packages/patches/gd-fix-test-on-i686.patch34
1 files changed, 0 insertions, 34 deletions
diff --git a/gnu/packages/patches/gd-fix-test-on-i686.patch b/gnu/packages/patches/gd-fix-test-on-i686.patch
deleted file mode 100644
index 6dd2e0fb03..0000000000
--- a/gnu/packages/patches/gd-fix-test-on-i686.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Disable part of the gdimagerotate test on architectures such as i686
-where intermediate floating-point operations are done with 80-bit long
-doubles, and typically later rounded to 64-bit doubles.  This double
-rounding causes small differences in the resulting pixel values
-compared with other architectures, causing the image comparison to
-fail.
-
-Patch by Mark H Weaver <mhw@netris.org>.
-
---- libgd-2.2.2/tests/gdimagerotate/bug00067.c	1969-12-31 19:00:00.000000000 -0500
-+++ libgd-2.2.2/tests/gdimagerotate/bug00067.c	2016-07-18 12:19:19.885423132 -0400
-@@ -1,5 +1,6 @@
- #include <stdio.h>
- #include <stdlib.h>
-+#include <float.h>
- #include "gd.h"
- 
- #include "gdtest.h"
-@@ -41,6 +42,7 @@
- 			return 1;
- 		}
- 
-+#if FLT_EVAL_METHOD != 2
- 		sprintf(filename, "bug00067_%03d_exp.png", angle);
- 		path = gdTestFilePath2("gdimagerotate", filename);
- 		if (!gdAssertImageEqualsToFile(path, exp)) {
-@@ -48,6 +50,7 @@
- 			error += 1;
- 		}
- 		free(path);
-+#endif
- 
- 		gdImageDestroy(exp);
- 	}