summary refs log tree commit diff
path: root/gnu/packages/patches/ghc-testsuite-recomp015-execstack.patch
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2024-01-15 23:05:37 +0100
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:44:27 +0200
commit13b5b5d10f32fde3543e7346c776f5734e6c9a6e (patch)
tree4ba7e6d9e92a73b97ec40885baff23eb13f6c6fc /gnu/packages/patches/ghc-testsuite-recomp015-execstack.patch
parent4840707013ead04c661d5cd3fe78b871254af895 (diff)
downloadguix-13b5b5d10f32fde3543e7346c776f5734e6c9a6e.tar.gz
gnu: ghc: Fix build with binutils ≥ 2.39.
ld warns about exec stack now, making some tests fail.  Fix them (and also
remove an unwarranted exec stack from libHSrts along with it).

* gnu/packages/patches/ghc-9-StgCRunAsm-only-when-needed.patch
* gnu/packages/patches/ghc-testsuite-recomp015-execstack.patch: New patches.
* gnu/local.mk (dist_patch_DATA): Register them.
* gnu/packages/haskell.scm (ghc-8.6, ghc-8.8, ghc-8.10, ghc-9.0, ghc-9.2,
ghc-9.4): Use them.

Change-Id: I8e5fc71d7394527d44ff37b1f9bd59d4971ec010
Diffstat (limited to 'gnu/packages/patches/ghc-testsuite-recomp015-execstack.patch')
-rw-r--r--gnu/packages/patches/ghc-testsuite-recomp015-execstack.patch10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/patches/ghc-testsuite-recomp015-execstack.patch b/gnu/packages/patches/ghc-testsuite-recomp015-execstack.patch
new file mode 100644
index 0000000000..cdaf5b180d
--- /dev/null
+++ b/gnu/packages/patches/ghc-testsuite-recomp015-execstack.patch
@@ -0,0 +1,10 @@
+--- a/testsuite/tests/driver/recomp015/Makefile   2024-01-13 16:22:42.643106725 +0100
++++ b/testsuite/tests/driver/recomp015/Makefile   2024-01-13 16:23:18.406867917 +0100
+@@ -26,6 +26,7 @@
+ 	# number of sections)
+ 	'$(TEST_HC)' $(TEST_HC_OPTS) Generate.hs
+ 	./Generate > ManySections.s
++	echo '.section .note.GNU-stack,"",@progbits' > ManySections.s
+ 	echo 'main = putStrLn "Running main..."' > Main.hs
+ 	'$(TEST_HC)' $(TEST_HC_OPTS) -c ManySections.s
+ 	'$(TEST_HC)' $(TEST_HC_OPTS) --make -O Main.hs ManySections.o