summary refs log tree commit diff
path: root/gnu/packages/patches/glib-tests-desktop.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-06-08 18:41:21 +0200
committerLudovic Courtès <ludo@gnu.org>2013-06-08 18:41:44 +0200
commit7bc5cc2b96188aad7f452309a0f4ae5aeecdf0e4 (patch)
treef6cc6d9cc68296490e7a0f48167b69ee817adeaa /gnu/packages/patches/glib-tests-desktop.patch
parent0d62efbe5a14804de6093be44c511c51bc6aa50c (diff)
downloadguix-7bc5cc2b96188aad7f452309a0f4ae5aeecdf0e4.tar.gz
gnu: glib: Update to 2.37.1.
* gnu/packages/glib.scm (glib): Update to 2.37.1.  Add Bash and tzdata
  as inputs.  Remove `glib-tests-timezone.patch'.  Augment `pre-build'
  phase to set `TZDIR', `XDG_CACHE_HOME', and to modify makefiles to
  honor $(TESTS_ENVIRONMENT).
* gnu/packages/patches/glib-tests-desktop.patch,
  gnu/packages/patches/glib-tests-homedir.patch: Update.
* gnu/packages/patches/glib-tests-timezone.patch: Remove.
* Makefile.am (dist_patch_DATA): Update accordingly.
Diffstat (limited to 'gnu/packages/patches/glib-tests-desktop.patch')
-rw-r--r--gnu/packages/patches/glib-tests-desktop.patch27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/patches/glib-tests-desktop.patch b/gnu/packages/patches/glib-tests-desktop.patch
index 85f2b06c9a..a92662886e 100644
--- a/gnu/packages/patches/glib-tests-desktop.patch
+++ b/gnu/packages/patches/glib-tests-desktop.patch
@@ -1,9 +1,9 @@
 Some GLib tests expect desktop things, such as an xterm, a MIME
 database, the `update-desktop-database' program, which we don't provide.
 
---- glib-2.34.3/gio/tests/appinfo.c	2013-01-16 18:20:00.000000000 +0100
-+++ glib-2.34.3/gio/tests/appinfo.c	2013-01-16 18:20:06.000000000 +0100
-@@ -384,14 +384,09 @@ main (int argc, char *argv[])
+--- glib-2.37.1/gio/tests/appinfo.c	2013-06-07 23:44:44.000000000 +0200
++++ glib-2.37.1/gio/tests/appinfo.c	2013-06-07 23:44:56.000000000 +0200
+@@ -497,16 +497,10 @@ main (int argc, char *argv[])
  
    g_test_add_func ("/appinfo/basic", test_basic);
    g_test_add_func ("/appinfo/text", test_text);
@@ -11,12 +11,15 @@ database, the `update-desktop-database' program, which we don't provide.
    g_test_add_func ("/appinfo/show-in", test_show_in);
    g_test_add_func ("/appinfo/commandline", test_commandline);
 -  g_test_add_func ("/appinfo/launch-context", test_launch_context);
+-  g_test_add_func ("/appinfo/launch-context-signals", test_launch_context_signals);
    g_test_add_func ("/appinfo/tryexec", test_tryexec);
 -  g_test_add_func ("/appinfo/associations", test_associations);
    g_test_add_func ("/appinfo/environment", test_environment);
 -  g_test_add_func ("/appinfo/startup-wm-class", test_startup_wm_class);
 -  g_test_add_func ("/appinfo/supported-types", test_supported_types);
    g_test_add_func ("/appinfo/from-keyfile", test_from_keyfile);
+ 
+   return g_test_run ();
 
 --- glib-2.34.3/gio/tests/contenttype.c	2013-01-16 21:22:29.000000000 +0100
 +++ glib-2.34.3/gio/tests/contenttype.c	2013-01-16 21:22:33.000000000 +0100
@@ -35,18 +38,16 @@ database, the `update-desktop-database' program, which we don't provide.
    return g_test_run ();
  }
 
---- glib-2.34.3/gio/tests/desktop-app-info.c	2013-01-16 21:30:00.000000000 +0100
-+++ glib-2.34.3/gio/tests/desktop-app-info.c	2013-01-16 21:30:02.000000000 +0100
-@@ -363,9 +363,5 @@ main (int   argc,
+--- glib-2.37.1/gio/tests/desktop-app-info.c	2013-06-07 23:46:28.000000000 +0200
++++ glib-2.37.1/gio/tests/desktop-app-info.c	2013-06-07 23:46:32.000000000 +0200
+@@ -385,6 +385,7 @@ main (int   argc,
    g_setenv ("XDG_DATA_HOME", basedir, TRUE);
    cleanup_subdirs (basedir);
    
--  g_test_add_func ("/desktop-app-info/delete", test_delete);
--  g_test_add_func ("/desktop-app-info/default", test_default);
--  g_test_add_func ("/desktop-app-info/fallback", test_fallback);
--  g_test_add_func ("/desktop-app-info/lastused", test_last_used);
- 
-   result = g_test_run ();
++  return 0;
+   g_test_add_func ("/desktop-app-info/delete", test_delete);
+   g_test_add_func ("/desktop-app-info/default", test_default);
+   g_test_add_func ("/desktop-app-info/fallback", test_fallback);
 
 
 -----------------------------
@@ -81,7 +82,7 @@ The test below depends on the availability /etc/passwd to dbus-daemon.
  {
    gint ret;
  
-+  exit (0);
++  return 0;
    setlocale (LC_ALL, "C");
  
    g_type_init ();