summary refs log tree commit diff
path: root/gnu/packages/patches/glib-tests-timer.patch
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2016-04-03 09:43:51 +0800
committerLudovic Courtès <ludo@gnu.org>2016-04-16 11:44:24 +0200
commit7c951767c09c7f97c0777d8a15d3de6559a2b4da (patch)
tree7bb735f814945331ac12301efa6d993192007ab1 /gnu/packages/patches/glib-tests-timer.patch
parent7dd99e5573581d391e2318a4b1a314e593ee0541 (diff)
downloadguix-7c951767c09c7f97c0777d8a15d3de6559a2b4da.tar.gz
gnu: glib: Disable tests in build phases instead of patches.
* gnu/packages/glib.scm (glib)[sources]: Remove glib-tests-desktop.patch,
glib-tests-prlimit.patch and glib-tests-gapplicatiotn.patch.
[arguments]: Add 'disable-falling-tests' phase.
* gnu/packages/patches/glib-tests-timer.patch: Adjust accordingly.
* gnu/packages/patches/glib-tests-desktop.patch,
  gnu/packages/patches/glib-tests-gapplication.patch,
  gnu/packages/patches/glib-tests-prlimit.patch: Remove files.
* gnu-system.am (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches/glib-tests-timer.patch')
-rw-r--r--gnu/packages/patches/glib-tests-timer.patch11
1 files changed, 0 insertions, 11 deletions
diff --git a/gnu/packages/patches/glib-tests-timer.patch b/gnu/packages/patches/glib-tests-timer.patch
index 1ac364fcc1..e37425c0c8 100644
--- a/gnu/packages/patches/glib-tests-timer.patch
+++ b/gnu/packages/patches/glib-tests-timer.patch
@@ -2,9 +2,6 @@
   fail depending on the elapsed microseconds.  Improve rounding by adding a
   fractional bit.
 
-* The /timer/stop test fails if compiler optimizations are enabled, which they
-  are by default.  Disable that test.
-
 --- glib-2.40.0/glib/tests/timer.c	2014-03-05 08:05:42.000000000 -0600
 +++ glib-2.40.0/glib/tests/timer.c	2014-07-10 16:33:12.746862822 -0500
 @@ -35,7 +35,7 @@
@@ -16,11 +13,3 @@
  
    g_timer_destroy (timer);
  }
-@@ -204,7 +204,6 @@
-   g_test_init (&argc, &argv, NULL);
- 
-   g_test_add_func ("/timer/basic", test_timer_basic);
--  g_test_add_func ("/timer/stop", test_timer_stop);
-   g_test_add_func ("/timer/continue", test_timer_continue);
-   g_test_add_func ("/timer/reset", test_timer_reset);
-   g_test_add_func ("/timeval/add", test_timeval_add);