summary refs log tree commit diff
path: root/gnu/packages/patches/gnunet-fix-scheduler.patch
diff options
context:
space:
mode:
authorSree Harsha Totakura <sreeharsha@totakura.in>2014-01-31 00:33:36 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-10 23:36:42 +0100
commit266b39fc26fff62e63c63f7f6bc8c92dfbc3f91a (patch)
tree94c3b4aaf1419b4c0206a34a8525910e1240a52d /gnu/packages/patches/gnunet-fix-scheduler.patch
parent93bfe3e27c42a60a3e6fa24278734e73d7386307 (diff)
downloadguix-266b39fc26fff62e63c63f7f6bc8c92dfbc3f91a.tar.gz
gnu: Add GNUnet.
* gnunet/packages/gnunet.scm (gnunet): New variable.
* gnu/package/patches/gnunet-fix-scheduler.patch: New file.
* gnu/package/patches/gnunet-fix-tests.patch: New file.
* gnu-system.am (dist_patch_DATA): Add the above two patch files.

Co-authored-by: Andreas Enge <andreas@enge.fr>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/gnunet-fix-scheduler.patch')
-rw-r--r--gnu/packages/patches/gnunet-fix-scheduler.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/gnunet-fix-scheduler.patch b/gnu/packages/patches/gnunet-fix-scheduler.patch
new file mode 100644
index 0000000000..1e0aef2a1a
--- /dev/null
+++ b/gnu/packages/patches/gnunet-fix-scheduler.patch
@@ -0,0 +1,13 @@
+Index: src/util/scheduler.c
+===================================================================
+--- src/util/scheduler.c	(revision 31745)
++++ src/util/scheduler.c	(working copy)
+@@ -1599,7 +1599,7 @@
+   int real_fd;
+ 
+   GNUNET_DISK_internal_file_handle_ (fd, &real_fd, sizeof (int));
+-  GNUNET_assert (real_fd > 0);
++  GNUNET_assert (real_fd >= 0);
+   return add_without_sets (
+       delay, priority,
+       on_read  ? real_fd : -1,