summary refs log tree commit diff
path: root/gnu/packages/patches/gobject-introspection-cc-1.72.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-15 10:20:32 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-15 10:20:32 -0400
commit3d297a0017210f1dd135592efb10846840a8af88 (patch)
tree8868c35a558a6288b5097d65bee42dda291178e4 /gnu/packages/patches/gobject-introspection-cc-1.72.patch
parent279349209e44aaae6ca2aba328fe2a4d2da99f12 (diff)
parent6737d8d3248301e65bc24291b1a776e4aa8c3648 (diff)
downloadguix-3d297a0017210f1dd135592efb10846840a8af88.tar.gz
Merge branch 'master' into staging
With resolved conflicts in:
	gnu/local.mk
	gnu/packages/freedesktop.scm
	gnu/packages/gnuzilla.scm
Diffstat (limited to 'gnu/packages/patches/gobject-introspection-cc-1.72.patch')
-rw-r--r--gnu/packages/patches/gobject-introspection-cc-1.72.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/gobject-introspection-cc-1.72.patch b/gnu/packages/patches/gobject-introspection-cc-1.72.patch
new file mode 100644
index 0000000000..d3b1df82af
--- /dev/null
+++ b/gnu/packages/patches/gobject-introspection-cc-1.72.patch
@@ -0,0 +1,15 @@
+Use gcc as the default C compiler if CC is not set.
+
+diff --git a/giscanner/__init__.py b/giscanner/__init__.py
+index 7c2f365a..607fe341 100644
+--- a/giscanner/__init__.py
++++ b/giscanner/__init__.py
+@@ -21,6 +21,8 @@ import os
+ builddir = os.environ.get('UNINSTALLED_INTROSPECTION_BUILDDIR')
+ if builddir is not None:
+     __path__.append(os.path.join(builddir, 'giscanner'))  # type: ignore  # mypy issue #1422
++if not 'CC' in os.environ:
++    os.environ['CC'] = 'gcc'
+ try:
+     from ._version import __version__
+ except ImportError: