summary refs log tree commit diff
path: root/gnu/packages/patches/graphicsmagick-CVE-2017-12936.patch
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-08-19 11:39:33 -0400
committerKei Kebreau <kei@openmailbox.org>2017-08-20 08:35:45 -0400
commit6d7d9d9507484773eff697a01f422ea984936373 (patch)
treeeb2fa4594f1b14e58805ef899992559648912a34 /gnu/packages/patches/graphicsmagick-CVE-2017-12936.patch
parenta8cd352304807ef60d06c35da07c5456f036688c (diff)
downloadguix-6d7d9d9507484773eff697a01f422ea984936373.tar.gz
gnu: graphicsmagick: Fix CVE-2017-{12935,12936,12937}.
* gnu/packages/patches/graphicsmagick-CVE-2017-12935.patch,
gnu/packages/patches/graphicsmagick-CVE-2017-12936.patch,
gnu/packages/patches/graphicsmagick-CVE-2017-12937.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/imagemagick.scm (graphicsmagick)[source]: Use them.
Diffstat (limited to 'gnu/packages/patches/graphicsmagick-CVE-2017-12936.patch')
-rw-r--r--gnu/packages/patches/graphicsmagick-CVE-2017-12936.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/graphicsmagick-CVE-2017-12936.patch b/gnu/packages/patches/graphicsmagick-CVE-2017-12936.patch
new file mode 100644
index 0000000000..7036f37438
--- /dev/null
+++ b/gnu/packages/patches/graphicsmagick-CVE-2017-12936.patch
@@ -0,0 +1,16 @@
+This patch comes from http://hg.code.sf.net/p/graphicsmagick/code/rev/be898b7c97bd.
+
+diff -ur a/coders/wmf.c b/coders/wmf.c
+--- a/coders/wmf.c	2016-09-05 15:20:23.000000000 -0400
++++ b/coders/wmf.c	2017-08-19 10:38:08.984187264 -0400
+@@ -2719,8 +2719,8 @@
+   if(image->exception.severity != UndefinedException)
+     ThrowException2(exception,
+                    CoderWarning,
+-                   ddata->image->exception.reason,
+-                   ddata->image->exception.description);
++                   image->exception.reason,
++                   image->exception.description);
+ 
+   if(logging)
+     (void) LogMagickEvent(CoderEvent,GetMagickModule(),"leave ReadWMFImage()");