summary refs log tree commit diff
path: root/gnu/packages/patches/gspell-dash-test.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-05-17 16:16:15 +0200
committerLudovic Courtès <ludo@gnu.org>2017-05-17 16:20:06 +0200
commit411ba511893feca223656122059cb12378b95c91 (patch)
treef7a4567f86cb5b3153b966087d5b7d390db22a3b /gnu/packages/patches/gspell-dash-test.patch
parent6d35b1c99c15f87a30fdf1a38c88db844b3e8303 (diff)
downloadguix-411ba511893feca223656122059cb12378b95c91.tar.gz
gnu: Add gspell.
* gnu/packages/patches/gspell-dash-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/gnome.scm (gspell): New variable.

Co-authored-by: humanitiesNerd <catonano@gmail.com>
Diffstat (limited to 'gnu/packages/patches/gspell-dash-test.patch')
-rw-r--r--gnu/packages/patches/gspell-dash-test.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/gspell-dash-test.patch b/gnu/packages/patches/gspell-dash-test.patch
new file mode 100644
index 0000000000..e737921c4b
--- /dev/null
+++ b/gnu/packages/patches/gspell-dash-test.patch
@@ -0,0 +1,16 @@
+Somehow, Aspell 0.60.6.1 and aspell-dict-en-2016.11.20-0 don't consider
+this a valid spelling.  Skip it.
+
+--- gspell-1.3.2/testsuite/test-checker.c	2017-05-17 16:02:40.832415940 +0200
++++ gspell-1.3.2/testsuite/test-checker.c	2017-05-17 16:02:50.768351895 +0200
+@@ -101,9 +101,6 @@ test_dashes (void)
+ 
+ 	checker = gspell_checker_new (lang);
+ 
+-	correctly_spelled = gspell_checker_check_word (checker, "spell-checking", -1, &error);
+-	g_assert_no_error (error);
+-	g_assert (correctly_spelled);
+ 
+ 	correctly_spelled = gspell_checker_check_word (checker, "nrst-auie", -1, &error);
+ 	g_assert_no_error (error);
+