summary refs log tree commit diff
path: root/gnu/packages/patches/guile-relocatable.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-08-21 06:01:14 -0400
committerMark H Weaver <mhw@netris.org>2016-08-21 06:30:15 -0400
commit0bd865101dfe501d8493104f635a452ee1d089d0 (patch)
treef643d4eaaecccfd688ce5a98c934bcc331d9477b /gnu/packages/patches/guile-relocatable.patch
parent1a93d0941eca2d669000cc6be111a70b6eab7f13 (diff)
downloadguix-0bd865101dfe501d8493104f635a452ee1d089d0.tar.gz
gnu: guile-static: Adapt guile-relocatable.patch to guile-2.0.12.
* gnu/packages/patches/guile-relocatable.patch: Adapt to guile-2.0.12.
Diffstat (limited to 'gnu/packages/patches/guile-relocatable.patch')
-rw-r--r--gnu/packages/patches/guile-relocatable.patch14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/patches/guile-relocatable.patch b/gnu/packages/patches/guile-relocatable.patch
index 077394cdde..2431495f24 100644
--- a/gnu/packages/patches/guile-relocatable.patch
+++ b/gnu/packages/patches/guile-relocatable.patch
@@ -1,8 +1,6 @@
 This patch changes Guile to use a default search path relative to the
 location of the `guile' binary, allowing it to be relocated.
 
-diff --git a/libguile/load.c b/libguile/load.c
-index af2ca45..19dd338 100644
 --- a/libguile/load.c
 +++ b/libguile/load.c
 @@ -26,6 +26,7 @@
@@ -12,8 +10,8 @@ index af2ca45..19dd338 100644
 +#include <libgen.h>
  
  #include "libguile/_scm.h"
- #include "libguile/private-gc.h" /* scm_getenv_int */
-@@ -255,6 +256,32 @@ scm_init_load_path ()
+ #include "libguile/alist.h"
+@@ -325,6 +326,32 @@
    SCM cpath = SCM_EOL;
  
  #ifdef SCM_LIBRARY_DIR
@@ -43,10 +41,10 @@ index af2ca45..19dd338 100644
 +  strcpy (ccache_dir, prefix);
 +  strcat (ccache_dir, "/lib/guile/2.0/ccache");
 +
-   env = getenv ("GUILE_SYSTEM_PATH");
+   env = scm_i_mirror_backslashes (getenv ("GUILE_SYSTEM_PATH"));
    if (env && strcmp (env, "") == 0)
      /* special-case interpret system-path=="" as meaning no system path instead
-@@ -263,10 +290,7 @@ scm_init_load_path ()
+@@ -333,10 +360,7 @@
    else if (env)
      path = scm_parse_path (scm_from_locale_string (env), path);
    else
@@ -56,9 +54,9 @@ index af2ca45..19dd338 100644
 -                       scm_from_locale_string (SCM_PKGDATA_DIR));
 +    path = scm_list_1 (scm_from_locale_string (module_dir));
  
-   env = getenv ("GUILE_SYSTEM_COMPILED_PATH");
+   env = scm_i_mirror_backslashes (getenv ("GUILE_SYSTEM_COMPILED_PATH"));
    if (env && strcmp (env, "") == 0)
-@@ -276,8 +300,7 @@ scm_init_load_path ()
+@@ -346,8 +370,7 @@
      cpath = scm_parse_path (scm_from_locale_string (env), cpath);
    else
      {