summary refs log tree commit diff
path: root/gnu/packages/patches/guile-ssh-channel-finalization.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-08-01 15:19:38 +0200
committerLudovic Courtès <ludo@gnu.org>2017-08-01 15:32:07 +0200
commit04b6d6f7f7a73e39dcff1e2bca3113ea567e2944 (patch)
treec9f9ab3a8c32f7decd9c5b80cfc3f0894d95df6d /gnu/packages/patches/guile-ssh-channel-finalization.patch
parent12235a124f7fc56d9cd4eaf76a453cf55d3026ea (diff)
downloadguix-04b6d6f7f7a73e39dcff1e2bca3113ea567e2944.tar.gz
gnu: guile-ssh: Update to 0.11.2.
* gnu/packages/ssh.scm (guile-ssh): Update to 0.11.2.
[source]: Remove 'patches', 'modules', and 'snippet'.
* gnu/packages/patches/guile-ssh-channel-finalization.patch,
gnu/packages/patches/guile-ssh-double-free.patch,
gnu/packages/patches/guile-ssh-rexec-bug.patch: Remove.
* gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches/guile-ssh-channel-finalization.patch')
-rw-r--r--gnu/packages/patches/guile-ssh-channel-finalization.patch28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/patches/guile-ssh-channel-finalization.patch b/gnu/packages/patches/guile-ssh-channel-finalization.patch
deleted file mode 100644
index 54b5055a20..0000000000
--- a/gnu/packages/patches/guile-ssh-channel-finalization.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Avoid asynchronous channel finalization, which could lead to segfaults due to
-libssh not being thread-safe: <https://bugs.gnu.org/26976>.
-
---- guile-ssh-0.11.0/modules/ssh/dist/node.scm	2017-06-13 14:37:44.861671297 +0200
-+++ guile-ssh-0.11.0/modules/ssh/dist/node.scm	2017-06-13 14:38:02.841580565 +0200
-@@ -391,11 +391,18 @@ listens on an expected port, return #f o
-   "Evaluate QUOTED-EXP on the node and return the evaluated result."
-   (let ((repl-channel (node-open-rrepl node)))
-     (rrepl-skip-to-prompt repl-channel)
--    (call-with-values (lambda () (rrepl-eval repl-channel quoted-exp))
--      (lambda vals
--        (and (node-stop-repl-server? node)
-+    (dynamic-wind
-+      (const #t)
-+      (lambda ()
-+        (rrepl-eval repl-channel quoted-exp))
-+      (lambda ()
-+        (when (node-stop-repl-server? node)
-              (node-stop-server node))
--        (apply values vals)))))
-+
-+        ;; Close REPL-CHANNEL right away to prevent finalization from
-+        ;; happening in another thread at the wrong time (see
-+        ;; <https://bugs.gnu.org/26976>.)
-+        (close-port repl-channel)))))
- 
- (define (node-eval-1 node quoted-exp)
-   "Evaluate QUOTED-EXP on the node and return the evaluated result.  The