summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-CVE-2015-2724-pt1.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-04 05:22:49 -0400
committerMark H Weaver <mhw@netris.org>2015-07-04 05:44:10 -0400
commit4463c0d2161f66c4ff0d52c50ff0a3a030686f1b (patch)
tree3f1aba42fd040420a2ee6964d6a5ec134adeb8be /gnu/packages/patches/icecat-CVE-2015-2724-pt1.patch
parent4cd86f5d52d6faac6668dc9853a5e5ecc9236ba9 (diff)
downloadguix-4463c0d2161f66c4ff0d52c50ff0a3a030686f1b.tar.gz
gnu: icecat: Fix CVE-2015-{2722,2724,2728,2733,2735,2736,2738,2739,2740,2743}.
* gnu/packages/patches/icecat-CVE-2015-2722-pt1.patch,
  gnu/packages/patches/icecat-CVE-2015-2722-pt2.patch,
  gnu/packages/patches/icecat-CVE-2015-2724-pt1.patch,
  gnu/packages/patches/icecat-CVE-2015-2724-pt2.patch,
  gnu/packages/patches/icecat-CVE-2015-2724-pt3.patch,
  gnu/packages/patches/icecat-CVE-2015-2724-pt4.patch,
  gnu/packages/patches/icecat-CVE-2015-2728-pt1.patch,
  gnu/packages/patches/icecat-CVE-2015-2728-pt2.patch,
  gnu/packages/patches/icecat-CVE-2015-2733-pt1.patch,
  gnu/packages/patches/icecat-CVE-2015-2733-pt2.patch,
  gnu/packages/patches/icecat-CVE-2015-2735.patch,
  gnu/packages/patches/icecat-CVE-2015-2736.patch,
  gnu/packages/patches/icecat-CVE-2015-2738.patch,
  gnu/packages/patches/icecat-CVE-2015-2739.patch,
  gnu/packages/patches/icecat-CVE-2015-2740.patch,
  gnu/packages/patches/icecat-CVE-2015-2743.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2015-2724-pt1.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2015-2724-pt1.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2015-2724-pt1.patch b/gnu/packages/patches/icecat-CVE-2015-2724-pt1.patch
new file mode 100644
index 0000000000..0b91b1ec86
--- /dev/null
+++ b/gnu/packages/patches/icecat-CVE-2015-2724-pt1.patch
@@ -0,0 +1,57 @@
+From 6465a9f57b13fdf3d21016a41973f13d1e7f447c Mon Sep 17 00:00:00 2001
+From: Bobby Holley <bobbyholley@gmail.com>
+Date: Wed, 13 May 2015 11:08:30 -0700
+Subject: [PATCH] Bug 1164567 - Grab the principal when we need it in
+ MediaDecodeTask. r=jww, a=sledru
+
+---
+ content/media/webaudio/MediaBufferDecoder.cpp | 17 ++++++++---------
+ 1 file changed, 8 insertions(+), 9 deletions(-)
+
+diff --git a/content/media/webaudio/MediaBufferDecoder.cpp b/content/media/webaudio/MediaBufferDecoder.cpp
+index b9409ad..ee6538c 100644
+--- a/content/media/webaudio/MediaBufferDecoder.cpp
++++ b/content/media/webaudio/MediaBufferDecoder.cpp
+@@ -101,13 +101,6 @@ public:
+   {
+     MOZ_ASSERT(aBuffer);
+     MOZ_ASSERT(NS_IsMainThread());
+-
+-    nsCOMPtr<nsPIDOMWindow> pWindow = do_QueryInterface(mDecodeJob.mContext->GetParentObject());
+-    nsCOMPtr<nsIScriptObjectPrincipal> scriptPrincipal =
+-      do_QueryInterface(pWindow);
+-    if (scriptPrincipal) {
+-      mPrincipal = scriptPrincipal->GetPrincipal();
+-    }
+   }
+ 
+   NS_IMETHOD Run();
+@@ -150,7 +143,6 @@ private:
+   WebAudioDecodeJob& mDecodeJob;
+   PhaseEnum mPhase;
+   nsCOMPtr<nsIThreadPool> mThreadPool;
+-  nsCOMPtr<nsIPrincipal> mPrincipal;
+   nsRefPtr<BufferDecoder> mBufferDecoder;
+   nsAutoPtr<MediaDecoderReader> mDecoderReader;
+ };
+@@ -179,9 +171,16 @@ MediaDecodeTask::CreateReader()
+ {
+   MOZ_ASSERT(NS_IsMainThread());
+ 
++
++  nsCOMPtr<nsIPrincipal> principal;
++  nsCOMPtr<nsIScriptObjectPrincipal> sop = do_QueryInterface(mDecodeJob.mContext->GetParentObject());
++  if (sop) {
++    principal = sop->GetPrincipal();
++  }
++
+   nsRefPtr<BufferMediaResource> resource =
+     new BufferMediaResource(static_cast<uint8_t*> (mBuffer),
+-                            mLength, mPrincipal, mContentType);
++                            mLength, principal, mContentType);
+ 
+   MOZ_ASSERT(!mBufferDecoder);
+   mBufferDecoder = new BufferDecoder(resource);
+-- 
+2.4.3
+