summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-CVE-2015-2724-pt4.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-15 15:28:36 -0400
committerMark H Weaver <mhw@netris.org>2015-07-15 15:43:23 -0400
commitb76c4152530b81d7ecc1c958202a3f06d407587d (patch)
tree842d7c190d0b21b4f8ca0d5594151a2efbf18a8a /gnu/packages/patches/icecat-CVE-2015-2724-pt4.patch
parente03f6d5e956b348c142d0ffd9f89af845f05eb86 (diff)
downloadguix-b76c4152530b81d7ecc1c958202a3f06d407587d.tar.gz
gnu: icecat: Update to 31.8.0-gnu1.
* gnu/packages/patches/icecat-enable-acceleration-and-webgl.patch: New file.
* gnu/packages/patches/icecat-CVE-2015-2722-pt1.patch,
  gnu/packages/patches/icecat-CVE-2015-2722-pt2.patch,
  gnu/packages/patches/icecat-CVE-2015-2724-pt1.patch,
  gnu/packages/patches/icecat-CVE-2015-2724-pt2.patch,
  gnu/packages/patches/icecat-CVE-2015-2724-pt3.patch,
  gnu/packages/patches/icecat-CVE-2015-2724-pt4.patch,
  gnu/packages/patches/icecat-CVE-2015-2728-pt1.patch,
  gnu/packages/patches/icecat-CVE-2015-2728-pt2.patch,
  gnu/packages/patches/icecat-CVE-2015-2733-pt1.patch,
  gnu/packages/patches/icecat-CVE-2015-2733-pt2.patch,
  gnu/packages/patches/icecat-CVE-2015-2735.patch,
  gnu/packages/patches/icecat-CVE-2015-2736.patch,
  gnu/packages/patches/icecat-CVE-2015-2738.patch,
  gnu/packages/patches/icecat-CVE-2015-2739.patch,
  gnu/packages/patches/icecat-CVE-2015-2740.patch,
  gnu/packages/patches/icecat-CVE-2015-2743.patch: Remove files.
* gnu-system.am (dist_patch_DATA): Remove them, and add the new file.
* gnu/packages/gnuzilla.scm (icecat): Update to 31.8.0-gnu1.  Remove the
  outdated patches and add the new one.
Diffstat (limited to 'gnu/packages/patches/icecat-CVE-2015-2724-pt4.patch')
-rw-r--r--gnu/packages/patches/icecat-CVE-2015-2724-pt4.patch65
1 files changed, 0 insertions, 65 deletions
diff --git a/gnu/packages/patches/icecat-CVE-2015-2724-pt4.patch b/gnu/packages/patches/icecat-CVE-2015-2724-pt4.patch
deleted file mode 100644
index 90c15e663e..0000000000
--- a/gnu/packages/patches/icecat-CVE-2015-2724-pt4.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-From 96dc9518fab0929293a8fc388f6a4a64d05b0f6f Mon Sep 17 00:00:00 2001
-From: Jan de Mooij <jdemooij@mozilla.com>
-Date: Wed, 10 Jun 2015 18:01:09 +0200
-Subject: [PATCH] Bug 1143679 - Make TryNoteIterIon behave more like
- Baseline/interpreter iterators. r=shu, a=lizzard
-
---HG--
-extra : transplant_source : W%D0%1FGe%29%2A%E2%BC%0C%09%3BH%92%2A%A0%5CO%FD%89
----
- js/src/jit/IonFrames.cpp | 20 +++++++++++++++++---
- 1 file changed, 17 insertions(+), 3 deletions(-)
-
-diff --git a/js/src/jit/IonFrames.cpp b/js/src/jit/IonFrames.cpp
-index 51f4301..3e41c0a 100644
---- a/js/src/jit/IonFrames.cpp
-+++ b/js/src/jit/IonFrames.cpp
-@@ -356,14 +356,20 @@ JitFrameIterator::machineState() const
-     return machine;
- }
- 
-+static uint32_t
-+NumArgAndLocalSlots(const InlineFrameIterator& frame)
-+{
-+    JSScript* script = frame.script();
-+    return CountArgSlots(script, frame.maybeCallee()) + script->nfixed();
-+}
-+
- static void
--CloseLiveIterator(JSContext* cx, const InlineFrameIterator& frame, uint32_t localSlot)
-+CloseLiveIterator(JSContext* cx, const InlineFrameIterator& frame, uint32_t stackSlot)
- {
-     SnapshotIterator si = frame.snapshotIterator();
- 
-     // Skip stack slots until we reach the iterator object.
--    uint32_t base = CountArgSlots(frame.script(), frame.maybeCallee()) + frame.script()->nfixed();
--    uint32_t skipSlots = base + localSlot - 1;
-+    uint32_t skipSlots = NumArgAndLocalSlots(frame) + stackSlot - 1;
- 
-     for (unsigned i = 0; i < skipSlots; i++)
-         si.skip();
-@@ -407,6 +413,11 @@ HandleExceptionIon(JSContext* cx, const InlineFrameIterator& frame, ResumeFromEx
-     if (!script->hasTrynotes())
-         return;
- 
-+    uint32_t base = NumArgAndLocalSlots(frame);
-+    SnapshotIterator si = frame.snapshotIterator();
-+    JS_ASSERT(si.numAllocations() >= base);
-+    const uint32_t stackDepth = si.numAllocations() - base;
-+
-     JSTryNote* tn = script->trynotes()->vector;
-     JSTryNote* tnEnd = tn + script->trynotes()->length;
- 
-@@ -417,6 +428,9 @@ HandleExceptionIon(JSContext* cx, const InlineFrameIterator& frame, ResumeFromEx
-         if (pcOffset >= tn->start + tn->length)
-             continue;
- 
-+        if (tn->stackDepth > stackDepth)
-+            continue;
-+
-         switch (tn->kind) {
-           case JSTRY_ITER: {
-             JS_ASSERT(JSOp(*(script->main() + tn->start + tn->length)) == JSOP_ENDITER);
--- 
-2.4.3
-