summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-armhf-xpcom.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-16 03:52:05 -0500
committerMark H Weaver <mhw@netris.org>2015-01-16 09:14:08 -0500
commit2a666e9cfddc5ec25831618bc376ab4ca6692527 (patch)
treeea21d6d2100179e96b5948a2e3361d838ba0b148 /gnu/packages/patches/icecat-armhf-xpcom.patch
parent57b7e1a62d2269bfd9d37f88bae92c829222f8fc (diff)
downloadguix-2a666e9cfddc5ec25831618bc376ab4ca6692527.tar.gz
gnu: icecat: Add fixes for CVE-2014-{8634,8638,8639,8641}.
* gnu/packages/patches/icecat-CVE-2014-8634-pt1.patch,
  gnu/packages/patches/icecat-CVE-2014-8634-pt2.patch,
  gnu/packages/patches/icecat-CVE-2014-8638-pt1.patch,
  gnu/packages/patches/icecat-CVE-2014-8638-pt2.patch,
  gnu/packages/patches/icecat-CVE-2014-8639.patch,
  gnu/packages/patches/icecat-CVE-2014-8641.patch,
  gnu/packages/patches/icecat-armhf-xpcom.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/gnuzilla.scm (icecat)[source]: Add patches.
Diffstat (limited to 'gnu/packages/patches/icecat-armhf-xpcom.patch')
-rw-r--r--gnu/packages/patches/icecat-armhf-xpcom.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/patches/icecat-armhf-xpcom.patch b/gnu/packages/patches/icecat-armhf-xpcom.patch
new file mode 100644
index 0000000000..e92c8bbf1e
--- /dev/null
+++ b/gnu/packages/patches/icecat-armhf-xpcom.patch
@@ -0,0 +1,25 @@
+From 06198585dae1e4079b4b52b49827fd5b826030b7 Mon Sep 17 00:00:00 2001
+From: Douglas Crosher <dtc-moz@scieneer.com>
+Date: Sun, 16 Nov 2014 00:29:23 +1100
+Subject: [PATCH] Bug 1050258 - ARM hard-float XPCOM: correct argument passing.
+ r=mjrosenb, a=bkerensa
+
+---
+ xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp b/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp
+index 946b7e3..c1c536b 100644
+--- a/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp
++++ b/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp
+@@ -224,6 +224,7 @@ static inline void copy_dword(uint32_t* &ireg_args,
+     *(uint64_t *)ireg_args = data;
+     ireg_args += 2;
+   } else {
++    ireg_args = end;
+     if ((uint32_t)stack_args & 4) {
+       stack_args++;
+     }
+-- 
+2.1.2
+