summary refs log tree commit diff
path: root/gnu/packages/patches/icecat-use-system-media-libs.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-01-29 21:21:20 -0500
committerMark H Weaver <mhw@netris.org>2019-01-29 22:29:42 -0500
commit24886c13892551f164aef20375939fc4e85942ab (patch)
tree46cb8e2e7c354a19be6e2f92c81e6fa3d39eee8a /gnu/packages/patches/icecat-use-system-media-libs.patch
parent948879eeda8fcacf6bdbf45111941eb5e964156e (diff)
downloadguix-24886c13892551f164aef20375939fc4e85942ab.tar.gz
gnu: icecat: Update to 60.5.0-guix1 [security-fixes].
Includes fixes for CVE-2018-18500, CVE-2018-18501, and CVE-2018-18505.

* gnu/packages/gnuzilla.scm (icecat): Update to 60.5.0-guix1.
[version]: Use %icecat-version.
[source]: Inherit from 'icecat-source'.  Remove obsolete patches.
* gnu/packages/patches/icecat-avoid-bundled-libraries.patch,
gnu/packages/patches/icecat-use-system-graphite2+harfbuzz.patch,
gnu/packages/patches/icecat-use-system-media-libs.patch: Adapt to 60.5.0.
Diffstat (limited to 'gnu/packages/patches/icecat-use-system-media-libs.patch')
-rw-r--r--gnu/packages/patches/icecat-use-system-media-libs.patch87
1 files changed, 43 insertions, 44 deletions
diff --git a/gnu/packages/patches/icecat-use-system-media-libs.patch b/gnu/packages/patches/icecat-use-system-media-libs.patch
index 648585a6f0..00c95fb82e 100644
--- a/gnu/packages/patches/icecat-use-system-media-libs.patch
+++ b/gnu/packages/patches/icecat-use-system-media-libs.patch
@@ -8,8 +8,8 @@ Changes to files within the bundled libraries are omitted, since those files
 are removed from Guix sources.  Modified for use with patch -p1, and to apply
 cleanly to GNU IceCat.
 
---- icecat-60.2.0/build/moz.configure/old.configure
-+++ icecat-60.2.0/build/moz.configure/old.configure
+--- icecat-60.5.0/build/moz.configure/old.configure
++++ icecat-60.5.0/build/moz.configure/old.configure
 @@ -273,7 +273,12 @@
      '--with-system-libvpx',
      '--with-system-nspr',
@@ -23,8 +23,8 @@ cleanly to GNU IceCat.
      '--with-system-zlib',
      '--with-thumb',
      '--with-thumb-interwork',
---- icecat-60.2.0/config/external/moz.build
-+++ icecat-60.2.0/config/external/moz.build
+--- icecat-60.5.0/config/external/moz.build
++++ icecat-60.5.0/config/external/moz.build
 @@ -23,12 +23,21 @@
  
  external_dirs += ['modules/xz-embedded']
@@ -61,8 +61,8 @@ cleanly to GNU IceCat.
      'media/mp4parse-rust',
      'media/psshparser'
  ]
---- icecat-60.2.0/config/system-headers.mozbuild
-+++ icecat-60.2.0/config/system-headers.mozbuild
+--- icecat-60.5.0/config/system-headers.mozbuild
++++ icecat-60.5.0/config/system-headers.mozbuild
 @@ -1324,6 +1324,28 @@
          'harfbuzz/hb.h',
      ]
@@ -92,19 +92,19 @@ cleanly to GNU IceCat.
  if CONFIG['MOZ_SYSTEM_LIBVPX']:
      system_headers += [
          'vpx_mem/vpx_mem.h',
---- icecat-60.2.0/dom/media/AudioStream.cpp
-+++ icecat-60.2.0/dom/media/AudioStream.cpp
-@@ -121,7 +121,9 @@
-   : mMonitor("AudioStream")
-   , mChannels(0)
-   , mOutChannels(0)
+--- icecat-60.5.0/dom/media/AudioStream.cpp
++++ icecat-60.5.0/dom/media/AudioStream.cpp
+@@ -128,7 +128,9 @@
+     : mMonitor("AudioStream"),
+       mChannels(0),
+       mOutChannels(0),
 +#ifndef MOZ_SYSTEM_SOUNDTOUCH
-   , mTimeStretcher(nullptr)
+       mTimeStretcher(nullptr),
 +#endif
-   , mDumpFile(nullptr)
-   , mState(INITIALIZED)
-   , mDataSource(aSource)
-@@ -142,9 +144,11 @@
+       mDumpFile(nullptr),
+       mState(INITIALIZED),
+       mDataSource(aSource),
+@@ -147,9 +149,11 @@
    if (mDumpFile) {
      fclose(mDumpFile);
    }
@@ -116,8 +116,8 @@ cleanly to GNU IceCat.
  #if defined(XP_WIN)
    if (XRE_IsContentProcess()) {
      audio::AudioNotificationReceiver::Unregister(this);
-@@ -168,7 +172,11 @@
- {
+@@ -170,7 +174,11 @@
+ nsresult AudioStream::EnsureTimeStretcherInitializedUnlocked() {
    mMonitor.AssertCurrentThreadOwns();
    if (!mTimeStretcher) {
 +#ifdef MOZ_SYSTEM_SOUNDTOUCH
@@ -128,8 +128,8 @@ cleanly to GNU IceCat.
      mTimeStretcher->setSampleRate(mAudioClock.GetInputRate());
      mTimeStretcher->setChannels(mOutChannels);
      mTimeStretcher->setPitch(1.0);
---- icecat-60.2.0/dom/media/AudioStream.h
-+++ icecat-60.2.0/dom/media/AudioStream.h
+--- icecat-60.5.0/dom/media/AudioStream.h
++++ icecat-60.5.0/dom/media/AudioStream.h
 @@ -15,7 +15,11 @@
  #include "mozilla/TimeStamp.h"
  #include "mozilla/UniquePtr.h"
@@ -142,7 +142,7 @@ cleanly to GNU IceCat.
  
  #if defined(XP_WIN)
  #include "mozilla/audio/AudioNotificationReceiver.h"
-@@ -297,7 +301,11 @@
+@@ -293,7 +297,11 @@
    uint32_t mChannels;
    uint32_t mOutChannels;
    AudioClock mAudioClock;
@@ -154,8 +154,8 @@ cleanly to GNU IceCat.
  
    // Output file for dumping audio
    FILE* mDumpFile;
---- icecat-60.2.0/dom/media/moz.build
-+++ icecat-60.2.0/dom/media/moz.build
+--- icecat-60.5.0/dom/media/moz.build
++++ icecat-60.5.0/dom/media/moz.build
 @@ -327,6 +327,21 @@
  
  DEFINES['MOZILLA_INTERNAL_API'] = True
@@ -178,8 +178,8 @@ cleanly to GNU IceCat.
  if CONFIG['MOZ_ANDROID_HLS_SUPPORT']:
      DEFINES['MOZ_ANDROID_HLS_SUPPORT'] = True
  
---- icecat-60.2.0/dom/media/platforms/ffmpeg/ffvpx/FFVPXRuntimeLinker.cpp
-+++ icecat-60.2.0/dom/media/platforms/ffmpeg/ffvpx/FFVPXRuntimeLinker.cpp
+--- icecat-60.5.0/dom/media/platforms/ffmpeg/ffvpx/FFVPXRuntimeLinker.cpp
++++ icecat-60.5.0/dom/media/platforms/ffmpeg/ffvpx/FFVPXRuntimeLinker.cpp
 @@ -15,9 +15,13 @@
  #include <windows.h>
  #endif
@@ -194,7 +194,7 @@ cleanly to GNU IceCat.
  
  namespace mozilla {
  
-@@ -64,6 +68,12 @@
+@@ -60,6 +64,12 @@
  
    sLinkStatus = LinkStatus_FAILED;
  
@@ -207,17 +207,17 @@ cleanly to GNU IceCat.
    // We retrieve the path of the lgpllibs library as this is where mozavcodec
    // and mozavutil libs are located.
    PathString lgpllibsname = GetLibraryName(nullptr, "lgpllibs");
-@@ -73,6 +83,7 @@
-   PathString path =
-     GetLibraryFilePathname(lgpllibsname.get(),
-                            (PRFuncPtr)&soundtouch::SoundTouch::getVersionId);
+@@ -68,6 +78,7 @@
+   }
+   PathString path = GetLibraryFilePathname(
+       lgpllibsname.get(), (PRFuncPtr)&soundtouch::SoundTouch::getVersionId);
 +#endif
    if (path.IsEmpty()) {
      return false;
    }
---- icecat-60.2.0/old-configure.in
-+++ icecat-60.2.0/old-configure.in
-@@ -2451,6 +2451,111 @@
+--- icecat-60.5.0/old-configure.in
++++ icecat-60.5.0/old-configure.in
+@@ -2417,6 +2417,111 @@
  fi
  fi # COMPILE_ENVIRONMENT
  
@@ -329,8 +329,8 @@ cleanly to GNU IceCat.
  dnl system libvpx Support
  dnl ========================================================
  MOZ_ARG_WITH_BOOL(system-libvpx,
---- icecat-60.2.0/toolkit/library/moz.build
-+++ icecat-60.2.0/toolkit/library/moz.build
+--- icecat-60.5.0/toolkit/library/moz.build
++++ icecat-60.5.0/toolkit/library/moz.build
 @@ -244,6 +244,21 @@
  if CONFIG['MOZ_SYSTEM_HUNSPELL']:
      OS_LIBS += CONFIG['MOZ_HUNSPELL_LIBS']
@@ -353,9 +353,9 @@ cleanly to GNU IceCat.
  if CONFIG['MOZ_SYSTEM_LIBEVENT']:
      OS_LIBS += CONFIG['MOZ_LIBEVENT_LIBS']
  
---- icecat-60.2.0/xpcom/build/XPCOMInit.cpp
-+++ icecat-60.2.0/xpcom/build/XPCOMInit.cpp
-@@ -138,7 +138,9 @@
+--- icecat-60.5.0/xpcom/build/XPCOMInit.cpp
++++ icecat-60.5.0/xpcom/build/XPCOMInit.cpp
+@@ -139,7 +139,9 @@
  
  #include "mozilla/ipc/GeckoChildProcessHost.h"
  
@@ -365,16 +365,15 @@ cleanly to GNU IceCat.
  #if defined(MOZ_VPX) && !defined(MOZ_VPX_NO_MEM_REPORTING)
  #if defined(HAVE_STDINT_H)
  // mozilla-config.h defines HAVE_STDINT_H, and then it's defined *again* in
-@@ -639,11 +641,13 @@
+@@ -635,10 +637,12 @@
    // this oddness.
    mozilla::SetICUMemoryFunctions();
  
 +#ifndef MOZ_OGG_NO_MEM_REPORTING
    // Do the same for libogg.
-   ogg_set_mem_functions(OggReporter::CountingMalloc,
-                         OggReporter::CountingCalloc,
-                         OggReporter::CountingRealloc,
-                         OggReporter::CountingFree);
+   ogg_set_mem_functions(
+       OggReporter::CountingMalloc, OggReporter::CountingCalloc,
+       OggReporter::CountingRealloc, OggReporter::CountingFree);
 +#endif
  
  #if defined(MOZ_VPX) && !defined(MOZ_VPX_NO_MEM_REPORTING)