summary refs log tree commit diff
path: root/gnu/packages/patches/jami-memory-usage.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-19 12:20:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-31 21:55:49 -0400
commitbdf0fce88e9aeec059be60acc3e94aa4ac785997 (patch)
tree131fe1a1d6d07a3f9981b82a3d5e053b5d0ccbc9 /gnu/packages/patches/jami-memory-usage.patch
parent1f466ed6be932526fc69e72ffd50390691d0d382 (diff)
downloadguix-bdf0fce88e9aeec059be60acc3e94aa4ac785997.tar.gz
gnu: libjami: Update to 20220726.1515.da8d1da.
* gnu/packages/patches/jami-fix-crash-on-quit.patch: Delete file.
* gnu/packages/patches/jami-images-loading.patch: Likewise.
* gnu/packages/patches/jami-libclient-audio-managers.patch: Likewise.
* gnu/packages/patches/jami-memory-usage.patch: Likewise.
* gnu/local.mk (dist_patch_DATA): De-register removed patches.
* gnu/packages/jami.scm (%jami-version): Update to 20220726.1515.da8d1da.
(libjami)[configure-flags]: Add '--disable-static'.
(jami-apply-custom-patches): Adjust for top directory renaming.
(%ffmpeg-default-configure-flags): Add muxer support
for g726 and g726le.  Add demuxer support for g723_1, g726 and g726le.  Add
encoder/decoder support for g726, g726le and g723_1.  Add decoder support for
g729.
(ffmpeg-jami)[patches]: Add 'libopusenc-reload-packet-loss-at-encode'.
(jami-libclient)[native-inputs]: New field.
[inputs]: Add ffmpeg-jami and libxkbcommon.
[propagated-inputs]: Replace qtbase-5 with qtbase.
Diffstat (limited to 'gnu/packages/patches/jami-memory-usage.patch')
-rw-r--r--gnu/packages/patches/jami-memory-usage.patch70
1 files changed, 0 insertions, 70 deletions
diff --git a/gnu/packages/patches/jami-memory-usage.patch b/gnu/packages/patches/jami-memory-usage.patch
deleted file mode 100644
index 75fcde8d0a..0000000000
--- a/gnu/packages/patches/jami-memory-usage.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From e796b3325d95b5ddd6162b5513c8325210f41fc5 Mon Sep 17 00:00:00 2001
-From: Sébastien Blin <sebastien.blin@savoirfairelinux.com>
-Date: Wed, 26 Jan 2022 11:37:07 -0500
-Subject: [PATCH] datatransferimage: improve memory usage
-
-+ Reduce listview caching' size by 50%
-+ use sourceSize to compress images and speedup loading
-+ use autoTransform: true to rotate images when needed
-
-Change-Id: Idf1babdc73f43aa6a79b89428c25c5d06856c0ef
-GitLab: #649
----
-
-diff --git a/client-qt/src/commoncomponents/DataTransferMessageDelegate.qml b/client-qt/src/commoncomponents/DataTransferMessageDelegate.qml
-index d017c03..ca5913e 100644
---- a/client-qt/src/commoncomponents/DataTransferMessageDelegate.qml
-+++ b/client-qt/src/commoncomponents/DataTransferMessageDelegate.qml
-@@ -255,9 +255,13 @@
-                     asynchronous: true
-                     width: sourceComponent.width
-                     height: sourceComponent.height
--                    sourceComponent: mediaInfo.isImage !== undefined ?
--                                         imageComp : mediaInfo.isAnimatedImage !== undefined ? animatedImageComp :
--                                         avComp
-+                    sourceComponent: {
-+                        if (mediaInfo.isImage)
-+                            return imageComp
-+                        if (mediaInfo.isAnimatedImage)
-+                            return animatedImageComp
-+                        return avComp
-+                    }
-                     Component {
-                         id: avComp
-                         WebEngineView {
-@@ -316,7 +320,7 @@
-                             fillMode: Image.PreserveAspectCrop
-                             mipmap: true
-                             antialiasing: true
--                            autoTransform: false
-+                            autoTransform: true
-                             asynchronous: true
-                             source: "file:///" + Body
-                             property real aspectRatio: implicitWidth / implicitHeight
-@@ -361,8 +365,10 @@
-                             fillMode: Image.PreserveAspectCrop
-                             mipmap: true
-                             antialiasing: true
--                            autoTransform: false
-+                            autoTransform: true
-                             asynchronous: true
-+                            sourceSize.width: width
-+                            sourceSize.height: height
-                             source: "file:///" + Body
-                             property real aspectRatio: implicitWidth / implicitHeight
-                             property real adjustedWidth: Math.min(maxSize,
-diff --git a/client-qt/src/mainview/components/MessageListView.qml b/client-qt/src/mainview/components/MessageListView.qml
-index 2b7c326..f65e67b 100644
---- a/client-qt/src/mainview/components/MessageListView.qml
-+++ b/client-qt/src/mainview/components/MessageListView.qml
-@@ -174,8 +174,8 @@
-     width: parent.width
-     // this offscreen caching is pretty huge
-     // displayMarginEnd may be removed
--    displayMarginBeginning: 4096
--    displayMarginEnd: 4096
-+    displayMarginBeginning: 2048
-+    displayMarginEnd: 2048
-     maximumFlickVelocity: 2048
-     verticalLayoutDirection: ListView.BottomToTop
-     boundsBehavior: Flickable.StopAtBounds