summary refs log tree commit diff
path: root/gnu/packages/patches/libgit2-0.25.1-mtime-0.patch
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@inbox.ru>2017-06-03 16:17:58 +0100
committerLudovic Courtès <ludo@gnu.org>2017-06-04 00:56:18 +0200
commit34cfeca84e62b92e4f2b32c5bf33fe4982253f48 (patch)
tree26b436e6ef2a4d0a03023888bb7e9f8304de2a56 /gnu/packages/patches/libgit2-0.25.1-mtime-0.patch
parent2ca9f51ec8125c0124362300853365a1a6c76ee5 (diff)
downloadguix-34cfeca84e62b92e4f2b32c5bf33fe4982253f48.tar.gz
gnu: libgit2: Fix Clar test framework.
This commit reverts 'patch' hack introduced in
a48a1071a686b250bf8b7982ca0ce8dda1d93c61 and fixes bug in the Clar test
framework.

Patch is proposed to Clar upstream as
<https://github.com/vmg/clar/pull/78>.

* gnu/local.mk: Add libgit2-0.25.1-mtime-0.patch.
* gnu/packages/patches/libgit2-0.25.1-mtime-0.patch: New file.
* gnu/packages/version-control.scm (libgit2)[arguments]:
Remove 'apply-patch' phase.
[inputs]: Remove "patch".
[source]: Add 'patches' field.

Signed-off-by: Sergei Trofimovich <slyfox@inbox.ru>
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/patches/libgit2-0.25.1-mtime-0.patch')
-rw-r--r--gnu/packages/patches/libgit2-0.25.1-mtime-0.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/libgit2-0.25.1-mtime-0.patch b/gnu/packages/patches/libgit2-0.25.1-mtime-0.patch
new file mode 100644
index 0000000000..a6fdb50fff
--- /dev/null
+++ b/gnu/packages/patches/libgit2-0.25.1-mtime-0.patch
@@ -0,0 +1,14 @@
+The Clar test framework has a bug whereby it skips the parsing phase
+on files with mtime=0.
+
+Reported upstream at <https://github.com/vmg/clar/pull/78>.
+
+diff --git a/tests/generate.py b/tests/generate.py
+index b639c8f..111ca41 100644
+--- a/tests/generate.py
++++ b/tests/generate.py
+@@ -63,3 +63,3 @@ class Module(object):
+ 
+-        self.mtime = 0
++        self.mtime = None # Guix sets all file mtimes to '0'
+         self.enabled = True