summary refs log tree commit diff
path: root/gnu/packages/patches/libmad-armv7-thumb-pt2.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-21 01:49:43 -0400
committerMark H Weaver <mhw@netris.org>2015-07-21 02:05:20 -0400
commitc0eac5a86246a2c8eb4fe3177a64cfc9687cf5e0 (patch)
treeef31bdae1d9aa09f3b99887c3523aee644aeaf25 /gnu/packages/patches/libmad-armv7-thumb-pt2.patch
parent4d85391059604959a010c39953bea5c62f52dc90 (diff)
downloadguix-c0eac5a86246a2c8eb4fe3177a64cfc9687cf5e0.tar.gz
gnu: libmad: Apply fixes for ARMv7 Thumb, etc.
* gnu/packages/patches/libmad-armv7-thumb-pt1.patch,
  gnu/packages/patches/libmad-armv7-thumb-pt2.patch,
  gnu/packages/patches/libmad-frame-length.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/mp3.scm (libmad)[source]: Add patches.
Diffstat (limited to 'gnu/packages/patches/libmad-armv7-thumb-pt2.patch')
-rw-r--r--gnu/packages/patches/libmad-armv7-thumb-pt2.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/patches/libmad-armv7-thumb-pt2.patch b/gnu/packages/patches/libmad-armv7-thumb-pt2.patch
new file mode 100644
index 0000000000..bb450967e6
--- /dev/null
+++ b/gnu/packages/patches/libmad-armv7-thumb-pt2.patch
@@ -0,0 +1,36 @@
+Copied from Debian.
+
+From: Dave Martin
+Subject: "rsc" doesnt exist anymore in thumb2
+
+diff --git a/fixed.h b/fixed.h
+index 4b58abf..ba4bc26 100644
+--- a/fixed.h
++++ b/fixed.h
+@@ -275,12 +275,25 @@ mad_fixed_t mad_f_mul_inline(mad_fixed_t x, mad_fixed_t y)
+ 	 : "+r" (lo), "+r" (hi)  \
+ 	 : "%r" (x), "r" (y))
+ 
++#ifdef __thumb__
++/* In Thumb-2, the RSB-immediate instruction is only allowed with a zero
++	operand.  If needed this code can also support Thumb-1 
++	(simply append "s" to the end of the second two instructions). */
++#  define MAD_F_MLN(hi, lo)  \
++    asm ("rsbs        %0, %0, #0\n\t"  \
++	 "sbc   %1, %1, %1\n\t"  \
++	 "sub   %1, %1, %2"  \
++	 : "+&r" (lo), "=&r" (hi)  \
++	 : "r" (hi)  \
++	 : "cc")
++#else /* ! __thumb__ */
+ #  define MAD_F_MLN(hi, lo)  \
+     asm ("rsbs	%0, %2, #0\n\t"  \
+ 	 "rsc	%1, %3, #0"  \
+-	 : "=r" (lo), "=r" (hi)  \
++	 : "=&r" (lo), "=r" (hi)  \
+ 	 : "0" (lo), "1" (hi)  \
+ 	 : "cc")
++#endif /* __thumb__ */
+ 
+ #  define mad_f_scale64(hi, lo)  \
+     ({ mad_fixed_t __result;  \