summary refs log tree commit diff
path: root/gnu/packages/patches/libmygpo-qt-missing-qt5-modules.patch
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2018-05-27 13:15:41 +0100
committerEfraim Flashner <efraim@flashner.co.il>2018-05-27 22:33:01 +0300
commit01c4869003884fc28b8993077474399b67d7be1c (patch)
treeed5aedfac10fe4803da0c2b42d2f7160d0d79b34 /gnu/packages/patches/libmygpo-qt-missing-qt5-modules.patch
parent3a69f5f2d348be38026c56ce3e9f04302e6d198e (diff)
downloadguix-01c4869003884fc28b8993077474399b67d7be1c.tar.gz
gnu: libmygpo-qt: Fix Qt 5.11 build.
The update to Qt 5.11.0 broke libmygpo-qt. It turned it was using a deprecated
CMake function (qt5_use_moduldes).  Let's pick up two upstream patches that
fix the issue: https://github.com/gpodder/libmygpo-qt/pull/15

As mentioned in the the pull request, there is now a test failure but it looks
harmless.

* gnu/packages/patches/libmygpo-qt-fix-qt-5.11.patch,
gnu/packages/patches/libmygpo-qt-missing-qt5-modules.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/music.scm (libmygpo-qt)[source]: Add patches.
[arguments]: Build tests but do not run them.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/patches/libmygpo-qt-missing-qt5-modules.patch')
-rw-r--r--gnu/packages/patches/libmygpo-qt-missing-qt5-modules.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/gnu/packages/patches/libmygpo-qt-missing-qt5-modules.patch b/gnu/packages/patches/libmygpo-qt-missing-qt5-modules.patch
new file mode 100644
index 0000000000..aa9ed2c0f7
--- /dev/null
+++ b/gnu/packages/patches/libmygpo-qt-missing-qt5-modules.patch
@@ -0,0 +1,51 @@
+From 0d76d960727018bddf04c6cc89552af69aaa7e55 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 15 Apr 2018 22:20:34 +0200
+Subject: [PATCH] Add missing Qt5Network, Qt5Test, make BUILD_WITH_QT4 more
+ strict
+
+---
+ CMakeLists.txt | 22 +++++++++++-----------
+ 1 file changed, 11 insertions(+), 11 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2a1f652..eb006d9 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -5,25 +5,25 @@ project( libmygpo-qt )
+ set( CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} ${CMAKE_CURRENT_SOURCE_DIR}/cmake/modules)
+ set( CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DQT_NO_CAST_FROM_ASCII -DQT_NO_CAST_TO_ASCII" )
+ 
+-option(BUILD_WITH_QT4 "Build libmygpo-qt with Qt4 no matter if Qt5 was found" OFF)
++option(BUILD_WITH_QT4 "Build libmygpo-qt with Qt4" OFF)
+ 
+ if( NOT BUILD_WITH_QT4 )
+-    find_package(Qt5Core QUIET)
+-    if( Qt5Core_DIR )
+-        set(MYGPO_QT_VERSION_SUFFIX 5)
+-
+-        macro(qt_wrap_cpp)
+-            qt5_wrap_cpp(${ARGN})
+-        endmacro()
++    if( MYGPO_BUILD_TESTS )
++        find_package(Qt5 REQUIRED COMPONENTS Core Network Test CONFIG)
++    else()
++        find_package(Qt5 REQUIRED COMPONENTS Core Network CONFIG)
+     endif()
++    set(MYGPO_QT_VERSION_SUFFIX 5)
++
++    macro(qt_wrap_cpp)
++        qt5_wrap_cpp(${ARGN})
++    endmacro()
+ 
+     # pkg-config names of QtCore and QtNetwork are Qt5Core and Qt5Network for
+     # Qt5
+     set(MYGPO_QT_MAJOR_VERSION "5")
+     set(MYGPO_QT4_QJSON_DEP "")
+-endif()
+-
+-if( NOT Qt5Core_DIR )
++else()
+     message(STATUS "Could not find Qt5, searching for Qt4 instead...")
+     message(STATUS "Qt4 Support is deprecated, building with Qt4 is no longer officially supported")
+     if( MYGPO_BUILD_TESTS )