summary refs log tree commit diff
path: root/gnu/packages/patches/libxml2-bug-747437.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-12-03 17:18:24 -0500
committerMark H Weaver <mhw@netris.org>2015-12-07 09:54:01 -0500
commit821060f3f66a45acd8b5726e8f7ecdd879754341 (patch)
tree977a3a46b044806118250135a9ca48d4bda1a163 /gnu/packages/patches/libxml2-bug-747437.patch
parent86c8f1daf8ed10f13f2b1e973a28845629b8ce47 (diff)
downloadguix-821060f3f66a45acd8b5726e8f7ecdd879754341.tar.gz
gnu: libxml2: Update to 2.9.3.
* gnu/packages/patches/libxml2-CVE-2015-1819.patch,
  gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch,
  gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch,
  gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch,
  gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch,
  gnu/packages/patches/libxml2-CVE-2015-8035.patch,
  gnu/packages/patches/libxml2-bug-737840.patch,
  gnu/packages/patches/libxml2-bug-738805.patch,
  gnu/packages/patches/libxml2-bug-746048.patch,
  gnu/packages/patches/libxml2-bug-747437.patch,
  gnu/packages/patches/libxml2-bug-751603.patch,
  gnu/packages/patches/libxml2-bug-751631.patch,
  gnu/packages/patches/libxml2-bug-754946.patch,
  gnu/packages/patches/libxml2-bug-754947.patch,
  gnu/packages/patches/libxml2-bug-755857.patch,
  gnu/packages/patches/libxml2-fix-catalog-corruption.patch,
  gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch,
  gnu/packages/patches/libxml2-node-sort-order-pt1.patch,
  gnu/packages/patches/libxml2-node-sort-order-pt2.patch: Delete files.
* gnu-system.am (dist_patch_DATA): Remove them.
* gnu/packages/xml.scm (libxml2): Update to 2.9.3.  Remove patches.
Diffstat (limited to 'gnu/packages/patches/libxml2-bug-747437.patch')
-rw-r--r--gnu/packages/patches/libxml2-bug-747437.patch46
1 files changed, 0 insertions, 46 deletions
diff --git a/gnu/packages/patches/libxml2-bug-747437.patch b/gnu/packages/patches/libxml2-bug-747437.patch
deleted file mode 100644
index ea2ef0ff53..0000000000
--- a/gnu/packages/patches/libxml2-bug-747437.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 8985cde70901c62d3f0f04da225e73b7344a52d7 Mon Sep 17 00:00:00 2001
-From: Martin von Gagern <Martin.vGagern@gmx.net>
-Date: Mon, 13 Apr 2015 16:32:14 +0800
-Subject: [PATCH] xmlMemUsed is not thread-safe
-
-For https://bugzilla.gnome.org/show_bug.cgi?id=747437
-just use the mutex to protect access to those variables
----
- xmlmemory.c | 14 ++++++++++++--
- 1 file changed, 12 insertions(+), 2 deletions(-)
-
-diff --git a/xmlmemory.c b/xmlmemory.c
-index a3dc737..f24fd6d 100644
---- a/xmlmemory.c
-+++ b/xmlmemory.c
-@@ -554,7 +554,12 @@ xmlMemoryStrdup(const char *str) {
- 
- int
- xmlMemUsed(void) {
--     return(debugMemSize);
-+    int res;
-+
-+    xmlMutexLock(xmlMemMutex);
-+    res = debugMemSize;
-+    xmlMutexUnlock(xmlMemMutex);
-+    return(res);
- }
- 
- /**
-@@ -567,7 +572,12 @@ xmlMemUsed(void) {
- 
- int
- xmlMemBlocks(void) {
--     return(debugMemBlocks);
-+    int res;
-+
-+    xmlMutexLock(xmlMemMutex);
-+    res = debugMemBlocks;
-+    xmlMutexUnlock(xmlMemMutex);
-+    return(res);
- }
- 
- #ifdef MEM_LIST
--- 
-2.6.3
-