summary refs log tree commit diff
path: root/gnu/packages/patches/libxml2-bug-747437.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-11-15 14:16:57 -0500
committerMark H Weaver <mhw@netris.org>2015-11-18 17:47:40 -0500
commitee6bb0cc763507b165674dbe03c6ae5d26c8da5c (patch)
tree34c4d1d29b5428f83113af81bc4464b432669c85 /gnu/packages/patches/libxml2-bug-747437.patch
parent328a14e869c01ae4e33120a08a5d60c719263684 (diff)
downloadguix-ee6bb0cc763507b165674dbe03c6ae5d26c8da5c.tar.gz
gnu: libxml2: Add fixes for CVE-2015-{1819,7941,7942,8035} and other bugs.
* gnu/packages/patches/libxml2-CVE-2015-1819.patch,
  gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch,
  gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch,
  gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch,
  gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch,
  gnu/packages/patches/libxml2-CVE-2015-8035.patch,
  gnu/packages/patches/libxml2-bug-737840.patch,
  gnu/packages/patches/libxml2-bug-738805.patch,
  gnu/packages/patches/libxml2-bug-746048.patch,
  gnu/packages/patches/libxml2-bug-747437.patch,
  gnu/packages/patches/libxml2-bug-751603.patch,
  gnu/packages/patches/libxml2-bug-751631.patch,
  gnu/packages/patches/libxml2-bug-754946.patch,
  gnu/packages/patches/libxml2-bug-754947.patch,
  gnu/packages/patches/libxml2-bug-755857.patch,
  gnu/packages/patches/libxml2-fix-catalog-corruption.patch,
  gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch,
  gnu/packages/patches/libxml2-node-sort-order-pt1.patch,
  gnu/packages/patches/libxml2-node-sort-order-pt2.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/xml.scm (libxml2)[source]: Add patches.
Diffstat (limited to 'gnu/packages/patches/libxml2-bug-747437.patch')
-rw-r--r--gnu/packages/patches/libxml2-bug-747437.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/patches/libxml2-bug-747437.patch b/gnu/packages/patches/libxml2-bug-747437.patch
new file mode 100644
index 0000000000..ea2ef0ff53
--- /dev/null
+++ b/gnu/packages/patches/libxml2-bug-747437.patch
@@ -0,0 +1,46 @@
+From 8985cde70901c62d3f0f04da225e73b7344a52d7 Mon Sep 17 00:00:00 2001
+From: Martin von Gagern <Martin.vGagern@gmx.net>
+Date: Mon, 13 Apr 2015 16:32:14 +0800
+Subject: [PATCH] xmlMemUsed is not thread-safe
+
+For https://bugzilla.gnome.org/show_bug.cgi?id=747437
+just use the mutex to protect access to those variables
+---
+ xmlmemory.c | 14 ++++++++++++--
+ 1 file changed, 12 insertions(+), 2 deletions(-)
+
+diff --git a/xmlmemory.c b/xmlmemory.c
+index a3dc737..f24fd6d 100644
+--- a/xmlmemory.c
++++ b/xmlmemory.c
+@@ -554,7 +554,12 @@ xmlMemoryStrdup(const char *str) {
+ 
+ int
+ xmlMemUsed(void) {
+-     return(debugMemSize);
++    int res;
++
++    xmlMutexLock(xmlMemMutex);
++    res = debugMemSize;
++    xmlMutexUnlock(xmlMemMutex);
++    return(res);
+ }
+ 
+ /**
+@@ -567,7 +572,12 @@ xmlMemUsed(void) {
+ 
+ int
+ xmlMemBlocks(void) {
+-     return(debugMemBlocks);
++    int res;
++
++    xmlMutexLock(xmlMemMutex);
++    res = debugMemBlocks;
++    xmlMutexUnlock(xmlMemMutex);
++    return(res);
+ }
+ 
+ #ifdef MEM_LIST
+-- 
+2.6.3
+