summary refs log tree commit diff
path: root/gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-12-03 17:18:24 -0500
committerMark H Weaver <mhw@netris.org>2015-12-07 09:54:01 -0500
commit821060f3f66a45acd8b5726e8f7ecdd879754341 (patch)
tree977a3a46b044806118250135a9ca48d4bda1a163 /gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch
parent86c8f1daf8ed10f13f2b1e973a28845629b8ce47 (diff)
downloadguix-821060f3f66a45acd8b5726e8f7ecdd879754341.tar.gz
gnu: libxml2: Update to 2.9.3.
* gnu/packages/patches/libxml2-CVE-2015-1819.patch,
  gnu/packages/patches/libxml2-CVE-2015-7941-pt1.patch,
  gnu/packages/patches/libxml2-CVE-2015-7941-pt2.patch,
  gnu/packages/patches/libxml2-CVE-2015-7942-pt1.patch,
  gnu/packages/patches/libxml2-CVE-2015-7942-pt2.patch,
  gnu/packages/patches/libxml2-CVE-2015-8035.patch,
  gnu/packages/patches/libxml2-bug-737840.patch,
  gnu/packages/patches/libxml2-bug-738805.patch,
  gnu/packages/patches/libxml2-bug-746048.patch,
  gnu/packages/patches/libxml2-bug-747437.patch,
  gnu/packages/patches/libxml2-bug-751603.patch,
  gnu/packages/patches/libxml2-bug-751631.patch,
  gnu/packages/patches/libxml2-bug-754946.patch,
  gnu/packages/patches/libxml2-bug-754947.patch,
  gnu/packages/patches/libxml2-bug-755857.patch,
  gnu/packages/patches/libxml2-fix-catalog-corruption.patch,
  gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch,
  gnu/packages/patches/libxml2-node-sort-order-pt1.patch,
  gnu/packages/patches/libxml2-node-sort-order-pt2.patch: Delete files.
* gnu-system.am (dist_patch_DATA): Remove them.
* gnu/packages/xml.scm (libxml2): Update to 2.9.3.  Remove patches.
Diffstat (limited to 'gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch')
-rw-r--r--gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch36
1 files changed, 0 insertions, 36 deletions
diff --git a/gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch b/gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch
deleted file mode 100644
index a87f79bf84..0000000000
--- a/gnu/packages/patches/libxml2-id-attrs-in-xmlSetTreeDoc.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From f54d6a929af2a570396f0595a0e29064c908c12e Mon Sep 17 00:00:00 2001
-From: Nick Wellnhofer <wellnhofer@aevum.de>
-Date: Fri, 19 Dec 2014 00:08:35 +0100
-Subject: [PATCH] Account for ID attributes in xmlSetTreeDoc
-
----
- tree.c | 11 +++++++++++
- 1 file changed, 11 insertions(+)
-
-diff --git a/tree.c b/tree.c
-index 6ec9223..c6323b4 100644
---- a/tree.c
-+++ b/tree.c
-@@ -2799,8 +2799,19 @@ xmlSetTreeDoc(xmlNodePtr tree, xmlDocPtr doc) {
- 	if(tree->type == XML_ELEMENT_NODE) {
- 	    prop = tree->properties;
- 	    while (prop != NULL) {
-+                if (prop->atype == XML_ATTRIBUTE_ID) {
-+                    xmlRemoveID(tree->doc, prop);
-+                }
-+
- 		prop->doc = doc;
- 		xmlSetListDoc(prop->children, doc);
-+
-+                if (xmlIsID(doc, tree, prop)) {
-+                    xmlChar *idVal = xmlNodeListGetString(doc, prop->children,
-+                                                          1);
-+                    xmlAddID(NULL, doc, idVal, prop);
-+                }
-+
- 		prop = prop->next;
- 	    }
- 	}
--- 
-2.6.3
-