summary refs log tree commit diff
path: root/gnu/packages/patches/libxml2-terminating-newline.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-25 22:52:29 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 12:06:28 +0200
commit7dfa2ff7804b4d4ffb4c256c5aaea92b2487b369 (patch)
treec4aba7a069299d97558b19b88e3fd25eff5ead93 /gnu/packages/patches/libxml2-terminating-newline.patch
parent138115b012cd5b223d8f12fc62e3bd13202be737 (diff)
downloadguix-7dfa2ff7804b4d4ffb4c256c5aaea92b2487b369.tar.gz
gnu: libxml2: Update to 2.9.14.
* gnu/packages/xml.scm (libxml2): Update to 2.9.14.
[source](uri): Use new download location.
[source](patches): Remove.
[arguments]: Don't attempt to move non-existing "doc" directory.
* gnu/packages/patches/libxml2-parent-pointers.patch,
gnu/packages/patches/libxml2-terminating-newline.patch,
gnu/packages/patches/libxml2-xpath-recursion-limit.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/libxml2-terminating-newline.patch')
-rw-r--r--gnu/packages/patches/libxml2-terminating-newline.patch33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/patches/libxml2-terminating-newline.patch b/gnu/packages/patches/libxml2-terminating-newline.patch
deleted file mode 100644
index 3f5c88dd4e..0000000000
--- a/gnu/packages/patches/libxml2-terminating-newline.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Fix a regression in 2.9.12 where serializing empty HTML documents would
-not add a terminating newline.
-
-  https://gitlab.gnome.org/GNOME/libxml2/-/issues/266
-
-Taken from upstream:
-
-  https://gitlab.gnome.org/GNOME/libxml2/-/commit/92d9ab4c28842a09ca2b76d3ff2f933e01b6cd6f
-
-diff --git a/HTMLtree.c b/HTMLtree.c
---- a/HTMLtree.c
-+++ b/HTMLtree.c
-@@ -763,11 +763,15 @@ htmlNodeDumpFormatOutput(xmlOutputBufferPtr buf, xmlDocPtr doc,
-             if (((xmlDocPtr) cur)->intSubset != NULL) {
-                 htmlDtdDumpOutput(buf, (xmlDocPtr) cur, NULL);
-             }
--            /* Always validate cur->parent when descending. */
--            if ((cur->parent == parent) && (cur->children != NULL)) {
--                parent = cur;
--                cur = cur->children;
--                continue;
-+            if (cur->children != NULL) {
-+                /* Always validate cur->parent when descending. */
-+                if (cur->parent == parent) {
-+                    parent = cur;
-+                    cur = cur->children;
-+                    continue;
-+                }
-+            } else {
-+                xmlOutputBufferWriteString(buf, "\n");
-             }
-             break;
-