summary refs log tree commit diff
path: root/gnu/packages/patches/libxml2-xpath-recursion-limit.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-06-25 22:52:29 +0200
committerMarius Bakke <marius@gnu.org>2022-06-26 12:06:28 +0200
commit7dfa2ff7804b4d4ffb4c256c5aaea92b2487b369 (patch)
treec4aba7a069299d97558b19b88e3fd25eff5ead93 /gnu/packages/patches/libxml2-xpath-recursion-limit.patch
parent138115b012cd5b223d8f12fc62e3bd13202be737 (diff)
downloadguix-7dfa2ff7804b4d4ffb4c256c5aaea92b2487b369.tar.gz
gnu: libxml2: Update to 2.9.14.
* gnu/packages/xml.scm (libxml2): Update to 2.9.14.
[source](uri): Use new download location.
[source](patches): Remove.
[arguments]: Don't attempt to move non-existing "doc" directory.
* gnu/packages/patches/libxml2-parent-pointers.patch,
gnu/packages/patches/libxml2-terminating-newline.patch,
gnu/packages/patches/libxml2-xpath-recursion-limit.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/libxml2-xpath-recursion-limit.patch')
-rw-r--r--gnu/packages/patches/libxml2-xpath-recursion-limit.patch20
1 files changed, 0 insertions, 20 deletions
diff --git a/gnu/packages/patches/libxml2-xpath-recursion-limit.patch b/gnu/packages/patches/libxml2-xpath-recursion-limit.patch
deleted file mode 100644
index 051196c635..0000000000
--- a/gnu/packages/patches/libxml2-xpath-recursion-limit.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Fix recursion accounting in XPath expressions:
-
-  https://gitlab.gnome.org/GNOME/libxml2/-/issues/264
-
-Taken from upstream:
-
-  https://gitlab.gnome.org/GNOME/libxml2/-/commit/3e1aad4fe584747fd7d17cc7b2863a78e2d21a77
-
-diff --git a/xpath.c b/xpath.c
---- a/xpath.c
-+++ b/xpath.c
-@@ -10983,7 +10983,7 @@ xmlXPathCompileExpr(xmlXPathParserContextPtr ctxt, int sort) {
-     }
- 
-     if (xpctxt != NULL)
--        xpctxt->depth -= 1;
-+        xpctxt->depth -= 10;
- }
- 
- /**