summary refs log tree commit diff
path: root/gnu/packages/patches/llvm-9-fix-lpad-miscompilation.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-14 01:10:29 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-14 11:41:07 -0500
commit9e4c24ef90545e242539a16a5ea28d7effc45933 (patch)
tree25de26367ff0a8e0b0c8fbdec65818666caaaf5a /gnu/packages/patches/llvm-9-fix-lpad-miscompilation.patch
parent199ebb12981e13a1a29501276bcb1675a53080b6 (diff)
downloadguix-9e4c24ef90545e242539a16a5ea28d7effc45933.tar.gz
gnu: llvm-9: Standardize patch level.
Having a non-standard (different than 1) patch level requirement means the
patches cannot be composed easily from different origins.  The following
command was used to remove one level from the llvm-9 patches:

  sed -e 's|^--- a/|--- |' -e 's|^+++ b/|+++ |' \
      gnu/packages/patches/llvm-9* -i

* gnu/packages/llvm.scm (llvm-9)[source]: Drop the patch-flags field.
Re-indent list of patches.
* gnu/packages/patches/llvm-9-fix-bitcast-miscompilation.patch: Strip one level.
* gnu/packages/patches/llvm-9-fix-lpad-miscompilation.patch: Likewise.
* gnu/packages/patches/llvm-9-fix-scev-miscompilation.patch: Likewise.
Diffstat (limited to 'gnu/packages/patches/llvm-9-fix-lpad-miscompilation.patch')
-rw-r--r--gnu/packages/patches/llvm-9-fix-lpad-miscompilation.patch8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/patches/llvm-9-fix-lpad-miscompilation.patch b/gnu/packages/patches/llvm-9-fix-lpad-miscompilation.patch
index 6cfe07e50a..9a97d82ddc 100644
--- a/gnu/packages/patches/llvm-9-fix-lpad-miscompilation.patch
+++ b/gnu/packages/patches/llvm-9-fix-lpad-miscompilation.patch
@@ -15,8 +15,8 @@ PR45261
 
 diff --git a/llvm/lib/CodeGen/SelectionDAG/FastISel.cpp b/llvm/lib/CodeGen/SelectionDAG/FastISel.cpp
 index 5ac3606dc662..2638b1e8a05c 100644
---- a/llvm/lib/CodeGen/SelectionDAG/FastISel.cpp
-+++ b/llvm/lib/CodeGen/SelectionDAG/FastISel.cpp
+--- llvm/lib/CodeGen/SelectionDAG/FastISel.cpp
++++ llvm/lib/CodeGen/SelectionDAG/FastISel.cpp
 @@ -225,6 +225,21 @@ static bool isRegUsedByPhiNodes(unsigned DefReg,
    return false;
  }
@@ -50,8 +50,8 @@ index 5ac3606dc662..2638b1e8a05c 100644
      }
 diff --git a/llvm/test/CodeGen/X86/sink-local-value.ll b/llvm/test/CodeGen/X86/sink-local-value.ll
 index b0e511ac1189..f7d861ac9b6c 100644
---- a/llvm/test/CodeGen/X86/sink-local-value.ll
-+++ b/llvm/test/CodeGen/X86/sink-local-value.ll
+--- llvm/test/CodeGen/X86/sink-local-value.ll
++++ llvm/test/CodeGen/X86/sink-local-value.ll
 @@ -145,6 +145,42 @@ try.cont:                                         ; preds = %entry, %lpad
  ; CHECK:         retl