summary refs log tree commit diff
path: root/gnu/packages/patches/mesa-skip-disk-cache-test.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-04-27 00:33:06 -0400
committerLeo Famulari <leo@famulari.name>2017-04-27 00:33:06 -0400
commit2018eea07bb00663d2f0cec9d9085d51afa4513b (patch)
treea55ca6062bd1808bdf2d3302b3b3026e6bc5c0f5 /gnu/packages/patches/mesa-skip-disk-cache-test.patch
parentbe58ffa4aa518686294726bdd83733eca4e6c03c (diff)
parent39d2d9a7abdde28830c39c1128986cad539c081d (diff)
downloadguix-2018eea07bb00663d2f0cec9d9085d51afa4513b.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/patches/mesa-skip-disk-cache-test.patch')
-rw-r--r--gnu/packages/patches/mesa-skip-disk-cache-test.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/mesa-skip-disk-cache-test.patch b/gnu/packages/patches/mesa-skip-disk-cache-test.patch
new file mode 100644
index 0000000000..4377110475
--- /dev/null
+++ b/gnu/packages/patches/mesa-skip-disk-cache-test.patch
@@ -0,0 +1,20 @@
+disk_cache_create() here looks up the users home directory from <pwd.h>
+which resolves to "/" in the build environment. I could not find an easy
+way to set the home directory to something else, so we disable this test
+for now.
+
+--- a/src/compiler/glsl/tests/cache_test.c
++++ b/src/compiler/glsl/tests/cache_test.c
+@@ -137,11 +137,6 @@
+    unsetenv("MESA_GLSL_CACHE_DIR");
+    unsetenv("XDG_CACHE_HOME");
+
+-   cache = disk_cache_create();
+-   expect_non_null(cache, "disk_cache_create with no environment variables");
+-
+-   disk_cache_destroy(cache);
+-
+    /* Test with XDG_CACHE_HOME set */
+    setenv("XDG_CACHE_HOME", CACHE_TEST_TMP "/xdg-cache-home", 1);
+    cache = disk_cache_create();
+