summary refs log tree commit diff
path: root/gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-10-07 14:54:08 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:12 -0500
commit802307fe6f6ce5cb89addc9ab25b5e488c443575 (patch)
treeba6766ab0f4c2142ca77f03ffe8374b6b8668e0b /gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch
parent0136d815803632abdd7ffb743edab4017575ee92 (diff)
downloadguix-802307fe6f6ce5cb89addc9ab25b5e488c443575.tar.gz
gnu: meson: Patch to allow installing to independent prefixes.
Meson goes to lengths at preventing installation to directories outside of the
main installation prefix.  This isn't convenient or desirable in Guix; patch
it out using a patch maintained by Nix.

* gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch: Add patch.
* gnu/local.mk (dist_patch_DATA): Register it.
* gnu/packages/build-tools.scm (meson): Use it.
Diffstat (limited to 'gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch')
-rw-r--r--gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch b/gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch
new file mode 100644
index 0000000000..f16daa8009
--- /dev/null
+++ b/gnu/packages/patches/meson-allow-dirs-outside-of-prefix.patch
@@ -0,0 +1,20 @@
+Source: https://raw.githubusercontent.com/NixOS/nixpkgs/master/pkgs/development/tools/build-managers/meson/allow-dirs-outside-of-prefix.patch
+--- a/mesonbuild/coredata.py
++++ b/mesonbuild/coredata.py
+@@ -506,7 +506,6 @@ class CoreData:
+             return value
+         if option.name.endswith('dir') and value.is_absolute() and \
+            option not in BULITIN_DIR_NOPREFIX_OPTIONS:
+-            # Value must be a subdir of the prefix
+             # commonpath will always return a path in the native format, so we
+             # must use pathlib.PurePath to do the same conversion before
+             # comparing.
+@@ -518,7 +517,7 @@ class CoreData:
+             try:
+                 value = value.relative_to(prefix)
+             except ValueError:
+-                raise MesonException(msg.format(option, value, prefix))
++                pass
+             if '..' in str(value):
+                 raise MesonException(msg.format(option, value, prefix))
+         return value.as_posix()