summary refs log tree commit diff
path: root/gnu/packages/patches/netsurf-system-utf8proc.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2017-11-05 11:56:59 -0600
committerEric Bavier <bavier@member.fsf.org>2017-11-05 07:46:08 -0600
commitd8799bd0df20ca8326f08afc916df78e51d926ca (patch)
tree38ab81078611aa4e74445295c4810d91636b9579 /gnu/packages/patches/netsurf-system-utf8proc.patch
parent772588bd223230d7786f64ef74c86a45c4d81b04 (diff)
downloadguix-d8799bd0df20ca8326f08afc916df78e51d926ca.tar.gz
gnu: netsurf: Update to 3.7.
For compatibility, dependents must be updated at the same time.

* gnu/packages/web.scm (libcss): Update to 0.7.0
(nsgenbind): Update to 0.5.
(netsurf): Update to 3.7.
[arguments]: Fix binary name in .desktop.  Adjust "docs" directory name.
* gnu/packages/patches/netsurf-system-utf8proc.patch: Adjust to new source.
Diffstat (limited to 'gnu/packages/patches/netsurf-system-utf8proc.patch')
-rw-r--r--gnu/packages/patches/netsurf-system-utf8proc.patch51
1 files changed, 18 insertions, 33 deletions
diff --git a/gnu/packages/patches/netsurf-system-utf8proc.patch b/gnu/packages/patches/netsurf-system-utf8proc.patch
index 254bf52c93..654d45d017 100644
--- a/gnu/packages/patches/netsurf-system-utf8proc.patch
+++ b/gnu/packages/patches/netsurf-system-utf8proc.patch
@@ -28,37 +28,22 @@ Work around upstream's lack of a pkg-config file and update API.
  
  #include "utils/errors.h"
  #include "utils/idna.h"
-@@ -250,7 +250,7 @@
- 		return NSERROR_NOMEM;
- 	}
- 
--	nfc_size = utf8proc_normalise(nfc_label, nfc_size,
-+	nfc_size = utf8proc_normalize_utf32(nfc_label, nfc_size,
- 		UTF8PROC_STABLE | UTF8PROC_COMPOSE);
- 	if (nfc_size < 0) {
- 		return NSERROR_NOMEM;
-@@ -565,7 +565,7 @@
- 	}
- 
- 	/* Perform NFC normalisation */
--	ucs4_len = utf8proc_normalise(ucs4, u_ucs4_len,
-+	ucs4_len = utf8proc_normalize_utf32(ucs4, u_ucs4_len,
- 		UTF8PROC_STABLE | UTF8PROC_COMPOSE);
- 	if (ucs4_len < 0) {
- 		free(ucs4);
---- netsurf-3.6/test/Makefile
-+++ netsurf-3.6/test/Makefile
-@@ -112,11 +112,11 @@
- 		-D_XOPEN_SOURCE=600 \
- 		-Itest -Iinclude -Icontent/handlers -Ifrontends -I. -I.. \
- 		-Dnsgtk \
--		$(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc libidn) \
-+		$(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libidn) \
- 		$(LIB_CFLAGS) \
- 		$(COV_CFLAGS)
- 
--TESTLDFLAGS := $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc libidn) -lz \
-+TESTLDFLAGS := $(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libidn) -lz -lutf8proc \
- 		$(LIB_LDFLAGS)\
- 		$(COV_LDFLAGS)
+--- netsurf-3.7/test/Makefile	2017-10-15 08:39:24.000000000 -0500
++++ netsurf-3.7/test/Makefile	2017-11-05 11:14:46.219013218 -0600
+@@ -139,14 +139,14 @@
+ 	-D_XOPEN_SOURCE=600 \
+ 	-Itest -Iinclude -Icontent/handlers -Ifrontends -I. -I.. \
+ 	-Dnsgtk \
+-	$(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) \
++	$(shell pkg-config --cflags libcurl libparserutils libwapcaplet libdom libnsutils) \
+ 	$(LIB_CFLAGS)
+ TESTCFLAGS := $(BASE_TESTCFLAGS) \
+ 	$(COV_CFLAGS) \
+ 	$(COV_CPPFLAGS)
+ 
+ TESTLDFLAGS := -L$(TESTROOT) \
+-	$(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils libutf8proc) -lz \
++	$(shell pkg-config --libs libcurl libparserutils libwapcaplet libdom libnsutils) -lz -lutf8proc \
+ 	$(LIB_LDFLAGS)\
+ 	$(COV_LDFLAGS)