summary refs log tree commit diff
path: root/gnu/packages/patches/opencv-fix-build-of-grfmt_jpeg2000.cpp.patch
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-20 23:19:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-20 23:23:40 +0100
commit5894b1210d689ec408db21184b85b0a6a1a5ca3e (patch)
treec60cd5e4d3b7e43649870730158ca2314895e949 /gnu/packages/patches/opencv-fix-build-of-grfmt_jpeg2000.cpp.patch
parentb934d88514284bf2c02ffba204c8b9b3e7272944 (diff)
downloadguix-5894b1210d689ec408db21184b85b0a6a1a5ca3e.tar.gz
gnu: opencv: Update to 4.5.4.
* gnu/packages/patches/opencv-fix-build-of-grfmt_jpeg2000.cpp.patch: Delete file.
* gnu/packages/patches/opencv-rgbd-aarch64-test-fix.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove patches.
* gnu/packages/image-processing.scm (opencv): Update to 4.5.4.
[source]: Remove patch; keep bundled quirc.
[arguments]: Build without ade; update build phase 'disable-broken-tests;
remove build phase 'add-ilmbase-include-path.
[native-inputs]: Update source hashes for opencv-contrib and opencv-extra.
[inputs]: Use new style; add imath and openblas; replace openexr-2 with
openexr.
[description]: Reformat first paragraph.
Diffstat (limited to 'gnu/packages/patches/opencv-fix-build-of-grfmt_jpeg2000.cpp.patch')
-rw-r--r--gnu/packages/patches/opencv-fix-build-of-grfmt_jpeg2000.cpp.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/gnu/packages/patches/opencv-fix-build-of-grfmt_jpeg2000.cpp.patch b/gnu/packages/patches/opencv-fix-build-of-grfmt_jpeg2000.cpp.patch
deleted file mode 100644
index 8deb60296a..0000000000
--- a/gnu/packages/patches/opencv-fix-build-of-grfmt_jpeg2000.cpp.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Thu, 13 Aug 2020 15:21:30 +0200
-Subject: [PATCH] gnu: opencv: Fix build with Jasper 2.0.19.
-
-Taken verbatim from upstream: <https://github.com/opencv/opencv/issues/17984>.
-
-From f66fc199a20882c546fa31142e9c0f5a8b3cf983 Mon Sep 17 00:00:00 2001
-From: Florian Jung <flo@windfis.ch>
-Date: Wed, 29 Jul 2020 18:51:55 +0200
-Subject: [PATCH] Fix build of grfmt_jpeg2000.cpp
-
-libjasper has recently changed `jas_matrix_get` from a macro to an inline function
-(389951d071 in https://github.com/jasper-software/jasper), causing the build to fail.
----
- modules/imgcodecs/src/grfmt_jpeg2000.cpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/modules/imgcodecs/src/grfmt_jpeg2000.cpp b/modules/imgcodecs/src/grfmt_jpeg2000.cpp
-index fe69f80c86f..0f4d28d6f4d 100644
---- a/modules/imgcodecs/src/grfmt_jpeg2000.cpp
-+++ b/modules/imgcodecs/src/grfmt_jpeg2000.cpp
-@@ -377,7 +377,7 @@ bool  Jpeg2KDecoder::readComponent8u( uchar *data, void *_buffer,
- 
-     for( y = 0; y < yend - ystart; )
-     {
--        jas_seqent_t* pix_row = &jas_matrix_get( buffer, y / ystep, 0 );
-+        jas_seqent_t* pix_row = jas_matrix_getref( buffer, y / ystep, 0 );
-         uchar* dst = data + (y - yoffset) * step - xoffset;
- 
-         if( xstep == 1 )
-@@ -443,7 +443,7 @@ bool  Jpeg2KDecoder::readComponent16u( unsigned short *data, void *_buffer,
- 
-     for( y = 0; y < yend - ystart; )
-     {
--        jas_seqent_t* pix_row = &jas_matrix_get( buffer, y / ystep, 0 );
-+        jas_seqent_t* pix_row = jas_matrix_getref( buffer, y / ystep, 0 );
-         ushort* dst = data + (y - yoffset) * step - xoffset;
- 
-         if( xstep == 1 )