summary refs log tree commit diff
path: root/gnu/packages/patches/perl-5.14-autosplit-default-time.patch
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-01-28 18:34:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-02-07 14:02:15 +0100
commit013086c3dbaa2e28dd1b3c21a7ebe51ac829a1eb (patch)
treef7fb6a850048b806d40183c3deea8eed638c85c5 /gnu/packages/patches/perl-5.14-autosplit-default-time.patch
parent26d9e6c9043e8dd6a40498b1d7fbeedf6e134d6d (diff)
downloadguix-013086c3dbaa2e28dd1b3c21a7ebe51ac829a1eb.tar.gz
gnu: Add perl-5.14.
* gnu/packages/patches/perl-5.14-autosplit-default-time.patch,
gnu/packages/patches/perl-5.14-module-pluggable-search.patch,
gnu/packages/patches/perl-5.14-no-sys-dirs.patch: New files.
* gnu/local.mk (dist_patch_DATA): Add them.
* gnu/packages/perl.scm (perl-5.14): New variable.
Diffstat (limited to 'gnu/packages/patches/perl-5.14-autosplit-default-time.patch')
-rw-r--r--gnu/packages/patches/perl-5.14-autosplit-default-time.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/perl-5.14-autosplit-default-time.patch b/gnu/packages/patches/perl-5.14-autosplit-default-time.patch
new file mode 100644
index 0000000000..e801ac9bfe
--- /dev/null
+++ b/gnu/packages/patches/perl-5.14-autosplit-default-time.patch
@@ -0,0 +1,15 @@
+AutoSplit will fail to create an index for files whose modification time is 0
+because its default time for a non-existent index is 1.  Set this default time
+to -1 instead.
+
+--- perl-5.16.1/cpan/AutoLoader/lib/AutoSplit.pm.orig	2012-02-14 22:44:36.000000000 -0600
++++ perl-5.16.1/cpan/AutoLoader/lib/AutoSplit.pm	2015-09-09 19:59:22.208708921 -0500
+@@ -361,7 +361,7 @@
+     my($al_idx_file) = catfile($autodir, $modpname, $IndexFile);
+ 
+     if ($check_mod_time){
+-	my($al_ts_time) = (stat("$al_idx_file"))[9] || 1;
++	my($al_ts_time) = (stat("$al_idx_file"))[9] || -1;
+ 	if ($al_ts_time >= $pm_mod_time and
+ 	    $al_ts_time >= $self_mod_time){
+ 	    print "AutoSplit skipped ($al_idx_file newer than $filename)\n"