summary refs log tree commit diff
path: root/gnu/packages/patches/perl-net-amazon-s3-moose-warning.patch
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-05-23 09:43:12 +0800
committer宋文武 <iyzsong@gmail.com>2015-05-23 09:43:12 +0800
commit86a81222cad9841c67e9d9bcd46c567383e9a34f (patch)
treed976896cba87c5de65d8fdc4bf0be85880c04153 /gnu/packages/patches/perl-net-amazon-s3-moose-warning.patch
parent3e3d47fc5347a5032fd2039831be1dc1d80576ed (diff)
parent8605321dd6f3c42590046be9d69112a8c8cf7cbf (diff)
downloadguix-86a81222cad9841c67e9d9bcd46c567383e9a34f.tar.gz
Merge branch 'master' into gtk-rebuild
Conflicts:
	gnu/packages/gtk.scm
Diffstat (limited to 'gnu/packages/patches/perl-net-amazon-s3-moose-warning.patch')
-rw-r--r--gnu/packages/patches/perl-net-amazon-s3-moose-warning.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/patches/perl-net-amazon-s3-moose-warning.patch b/gnu/packages/patches/perl-net-amazon-s3-moose-warning.patch
new file mode 100644
index 0000000000..c6408d5251
--- /dev/null
+++ b/gnu/packages/patches/perl-net-amazon-s3-moose-warning.patch
@@ -0,0 +1,17 @@
+Patch borrowed from nixpkgs.  Works around warning message produced by the
+current version of Moose:
+
+"Passing a list of values to enum is deprecated. Enum values should be wrapped
+in an arrayref."
+
+--- Net-Amazon-S3-0.60/lib/Net/Amazon/S3/Client/Object.pm	2015-04-15 16:18:47.226410022 -0500
++++ Net-Amazon-S3-0.60/lib/Net/Amazon/S3/Client/Object.pm	2015-04-15 16:19:25.410408425 -0500
+@@ -19,7 +19,7 @@
+     [ qw(private public-read public-read-write authenticated-read) ];
+ 
+ enum 'StorageClass' =>
+-    qw(standard reduced_redundancy);
++    [ qw(standard reduced_redundancy) ];
+ 
+ has 'client' =>
+     ( is => 'ro', isa => 'Net::Amazon::S3::Client', required => 1 );