summary refs log tree commit diff
path: root/gnu/packages/patches/perl-www-curl-fix-struct-void.patch
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-15 23:45:34 +0100
committerMarius Bakke <marius@gnu.org>2020-11-15 23:45:34 +0100
commit4e5e05d40908e9f1336ffc5a6c4928ab61ad034c (patch)
treead6d6be0ece396ba3353871a5691e514253508f8 /gnu/packages/patches/perl-www-curl-fix-struct-void.patch
parent2c400ae94207b3b84fcdcaa21c122076c050d307 (diff)
parente1fa3ea9fe8d01dd124c5e304bde9243876378ba (diff)
downloadguix-4e5e05d40908e9f1336ffc5a6c4928ab61ad034c.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/perl-www-curl-fix-struct-void.patch')
-rw-r--r--gnu/packages/patches/perl-www-curl-fix-struct-void.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/patches/perl-www-curl-fix-struct-void.patch b/gnu/packages/patches/perl-www-curl-fix-struct-void.patch
new file mode 100644
index 0000000000..b150950668
--- /dev/null
+++ b/gnu/packages/patches/perl-www-curl-fix-struct-void.patch
@@ -0,0 +1,24 @@
+From: Tobias Geerinckx-Rice <me@tobias.gr>
+Date: Sat, 14 Nov 2020 15:40:56 +0100
+Subject: [PATCH] gnu: perl-www-curl: Fix struct void* usage.
+
+Copied verbatim from Gentoo[0].  Fixes:
+
+  Curl.xs:76:12: error: expected ‘{’ before ‘void’
+       struct void *curlm;
+              ^~~~
+  Curl.xs:76:12: error: two or more data types in declaration specifiers
+
+[0]: https://694466.bugs.gentoo.org/attachment.cgi?id=595098
+
+--- WWW-Curl-4.17/Curl.xs	2014-02-21 18:08:30.000000000 +0200
++++ WWW-Curl-4.17.new/Curl.xs	2019-11-05 21:44:55.434395739 +0200
+@@ -73,7 +73,7 @@ typedef struct {
+ #ifdef __CURL_MULTI_H
+     struct CURLM *curlm;
+ #else
+-    struct void *curlm;
++    void *curlm;
+ #endif
+ } perl_curl_multi;
+