summary refs log tree commit diff
path: root/gnu/packages/patches/python-3-search-paths.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-05 20:46:57 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-02-09 21:53:41 +0100
commita1635de0ce12979d74ba3796d460c01e58b198f3 (patch)
tree1dde7fba113a55878e2607142c3af0eb122e6302 /gnu/packages/patches/python-3-search-paths.patch
parent3670ea70e2e932969a3ffc0acf75a714c7b42540 (diff)
downloadguix-a1635de0ce12979d74ba3796d460c01e58b198f3.tar.gz
gnu: python: Fix FTBFS with GCC >= 6.
* gnu/packages/patches/python-3-search-paths.patch: s/C_INCLUDE_PATH/CPATH.
* gnu/packages/patches/python-2.7-search-paths.patch: Ditto.
Diffstat (limited to 'gnu/packages/patches/python-3-search-paths.patch')
-rw-r--r--gnu/packages/patches/python-3-search-paths.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/patches/python-3-search-paths.patch b/gnu/packages/patches/python-3-search-paths.patch
index 73e3f4ccf5..c824705633 100644
--- a/gnu/packages/patches/python-3-search-paths.patch
+++ b/gnu/packages/patches/python-3-search-paths.patch
@@ -1,4 +1,4 @@
-Make sure the build system honors C_INCLUDE_PATH and LIBRARY_PATH when
+Make sure the build system honors CPATH and LIBRARY_PATH when
 looking for headers and libraries.
 
 --- setup.py	2015-10-07 23:32:58.891329173 +0200
@@ -10,7 +10,7 @@ looking for headers and libraries.
 -            lib_dirs = self.compiler.library_dirs + system_lib_dirs
 -            inc_dirs = self.compiler.include_dirs + system_include_dirs
 +            lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
-+            inc_dirs = os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
++            inc_dirs = os.getenv('CPATH', '').split(os.pathsep)
          else:
              # Add the sysroot paths. 'sysroot' is a compiler option used to
              # set the logical path of the standard system headers and