summary refs log tree commit diff
path: root/gnu/packages/patches/python-genshi-isstring-helper.patch
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-10 18:01:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-10 18:21:59 +0200
commit7c8b1bf66448d072be67682ed3ce618da831f72f (patch)
treea48e5a2fa054bdc02a6c3806107bd1dfd9a3a98e /gnu/packages/patches/python-genshi-isstring-helper.patch
parent83397e07862198cf3145112c8100fd8dd142fd21 (diff)
downloadguix-7c8b1bf66448d072be67682ed3ce618da831f72f.tar.gz
gnu: python-genshi: Update to 0.7.1.
* gnu/packages/python-web.scm (python-genshi): Update to 0.7.1.
[source]: Use GIT-FETCH and GIT-FILE-NAME. Remove patches.
* gnu/packages/patches/python-genshi-add-support-for-python-3.4-AST.patch,
gnu/packages/patches/python-genshi-buildable-on-python-2.7.patch,
gnu/packages/patches/python-genshi-disable-speedups-on-python-3.3.patch,
gnu/packages/patches/python-genshi-fix-tests-on-python-3.5.patch,
gnu/packages/patches/python-genshi-isstring-helper.patch,
gnu/packages/patches/python-genshi-stripping-of-unsafe-script-tags.patch:
Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches/python-genshi-isstring-helper.patch')
-rw-r--r--gnu/packages/patches/python-genshi-isstring-helper.patch37
1 files changed, 0 insertions, 37 deletions
diff --git a/gnu/packages/patches/python-genshi-isstring-helper.patch b/gnu/packages/patches/python-genshi-isstring-helper.patch
deleted file mode 100644
index 4f6c19bba9..0000000000
--- a/gnu/packages/patches/python-genshi-isstring-helper.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From cc5e07284f44cdd9beec178c69070a53f55d1323 Mon Sep 17 00:00:00 2001
-From: Simon Cross <hodgestar@gmail.com>
-Date: Sun, 16 Feb 2014 18:43:20 +0000
-Subject: [PATCH 03/15] Add isstring helper.
-
----
- genshi/compat.py | 10 +++++++++-
- 1 file changed, 9 insertions(+), 1 deletion(-)
-
-diff --git a/genshi/compat.py b/genshi/compat.py
-index 9787325..6574e39 100644
---- a/genshi/compat.py
-+++ b/genshi/compat.py
-@@ -35,6 +35,15 @@ else:
-                 'Python 2 compatibility function. Not usable in Python 3.')
- 
- 
-+# We need to test if an object is an instance of a string type in places
-+
-+if IS_PYTHON2:
-+    def isstring(obj):
-+        return isinstance(obj, basestring)
-+else:
-+    def isstring(obj):
-+        return isinstance(obj, str)
-+
- # We need to differentiate between StringIO and BytesIO in places
- 
- if IS_PYTHON2:
-@@ -112,4 +121,3 @@ except NameError:
-             if not x:
-                 return False
-         return True
--
--- 
-2.12.0
-