summary refs log tree commit diff
path: root/gnu/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-02-06 23:18:52 -0500
committerLeo Famulari <leo@famulari.name>2022-02-16 11:57:14 -0500
commitd2bb4847b96e51b71126778bb16daa7674a6690c (patch)
tree30b42d5f903857a55e30fb1756a52c0f475ebc60 /gnu/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch
parent5fffd8352b97295303c4782a5835566338119382 (diff)
downloadguix-d2bb4847b96e51b71126778bb16daa7674a6690c.tar.gz
gnu: Remove leftover patch files.
These patches aren't used anywhere in Guix and we forgot to remove them.

* gnu/packages/patches/bash-reproducible-linux-pgrp-pipe.patch,
gnu/packages/patches/ghc-monad-par-fix-tests.patch,
gnu/packages/patches/glibc-CVE-2018-11236.patch,
gnu/packages/patches/glibc-CVE-2018-11237.patch,
gnu/packages/patches/glibc-hurd-magic-pid.patch,
gnu/packages/patches/grocsvs-dont-use-admiral.patch,
gnu/packages/patches/hydra-disable-darcs-test.patch,
gnu/packages/patches/inkscape-poppler-0.76.patch,
gnu/packages/patches/libvirt-create-machine-cgroup.patch,
gnu/packages/patches/linux-libre-arm64-generic-pinebook-lcd.patch,
gnu/packages/patches/marble-qt-add-qt-headers.patch,
gnu/packages/patches/maven-enforcer-api-fix-old-dependencies.patch,
gnu/packages/patches/mescc-tools-boot.patch,
gnu/packages/patches/nettle-3.5-CVE-2021-3580-pt1.patch,
gnu/packages/patches/nettle-3.5-CVE-2021-3580-pt2.patch,
gnu/packages/patches/nettle-3.5-check-_pkcs1_sec_decrypt-msg-len.patch,
gnu/packages/patches/ocaml-Add-a-.file-directive.patch,
gnu/packages/patches/ocaml-CVE-2015-8869.patch,
gnu/packages/patches/ocaml-bitstring-fix-configure.patch,
gnu/packages/patches/ocaml-enable-ocamldoc-reproducibility.patch,
gnu/packages/patches/openbabel-fix-crash-on-nwchem-output.patch,
gnu/packages/patches/openjdk-14-builtins.patch,
gnu/packages/patches/openssl-c-rehash-in.patch,
gnu/packages/patches/openssl-runpath.patch,
gnu/packages/patches/passwordsafe-meson-remove-extra-argument.patch,
gnu/packages/patches/patchutils-test-perms.patch,
gnu/packages/patches/python-CVE-2018-14647.patch,
gnu/packages/patches/python-CVE-2020-26116.patch,
gnu/packages/patches/python-axolotl-AES-fix.patch,
gnu/packages/patches/python-babel-fix-parse-future-test.patch,
gnu/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch,
gnu/packages/patches/python-pytest-asyncio-python-3.8.patch,
gnu/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch,
gnu/packages/patches/qt4-ldflags.patch,
gnu/packages/patches/rust-coresimd-doctest.patch,
gnu/packages/patches/streamlink-update-test.patch,
gnu/packages/patches/tcc-boot-0.9.27.patch,
gnu/packages/patches/vtk-8-fix-freetypetools-build-failure.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch')
-rw-r--r--gnu/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/gnu/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch b/gnu/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch
deleted file mode 100644
index 6f067763b5..0000000000
--- a/gnu/packages/patches/python-matplotlib-run-under-wayland-gtk3.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From: Tobias Geerinckx-Rice <me@tobias.gr>
-Date: Tue, 02 Mar 2021 18:04:33 +0100
-Subject: [PATCH] gnu: python-matplotlib: Run under Wayland with GTK3.
-
-Adopted from upstream's fix[0] for
-<https://github.com/matplotlib/matplotlib/issues/19405>.
-
-[0]: https://github.com/liuyun88/matplotlib/commit/3d5000463bd23cb046681220f5511f07743f7d82
-
----
-diff -Naur a/lib/matplotlib/backends/backend_gtk3.py b/lib/matplotlib/backends/backend_gtk3.py
---- a/lib/matplotlib/backends/backend_gtk3.py	2019-11-21 23:47:05.000000000 +0100
-+++ b/lib/matplotlib/backends/backend_gtk3.py	2021-03-02 18:00:57.479929766 +0100
-@@ -42,11 +42,12 @@
- 
- try:
-+    _display = Gdk.Display.get_default()
-     cursord = {
--        cursors.MOVE          : Gdk.Cursor.new(Gdk.CursorType.FLEUR),
--        cursors.HAND          : Gdk.Cursor.new(Gdk.CursorType.HAND2),
--        cursors.POINTER       : Gdk.Cursor.new(Gdk.CursorType.LEFT_PTR),
--        cursors.SELECT_REGION : Gdk.Cursor.new(Gdk.CursorType.TCROSS),
--        cursors.WAIT          : Gdk.Cursor.new(Gdk.CursorType.WATCH),
-+        cursors.MOVE          : Gdk.Cursor.new_from_name(_display, "move"),
-+        cursors.HAND          : Gdk.Cursor.new_from_name(_display, "pointer"),
-+        cursors.POINTER       : Gdk.Cursor.new_from_name(_display, "default"),
-+        cursors.SELECT_REGION : Gdk.Cursor.new_from_name(_display, "crosshair"),
-+        cursors.WAIT          : Gdk.Cursor.new_from_name(_display, "wait"),
-     }
- except TypeError as exc:
-     # Happens when running headless.  Convert to ImportError to cooperate with