summary refs log tree commit diff
path: root/gnu/packages/patches/python-robotframework-ug2html.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-21 23:39:43 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-03-21 23:39:43 -0400
commita9429c8f2207841c649438187d6e19046d323a16 (patch)
treea06e4b8a87b6a42742cf6750276746a10b6c2139 /gnu/packages/patches/python-robotframework-ug2html.patch
parentf0136b36ae8c1e9c174043bd50e0e24413c0f345 (diff)
parent49b350fafc2c3ea1db66461b73d4e304cd13ec92 (diff)
downloadguix-a9429c8f2207841c649438187d6e19046d323a16.tar.gz
Merge branch 'staging' into core-updates.
Diffstat (limited to 'gnu/packages/patches/python-robotframework-ug2html.patch')
-rw-r--r--gnu/packages/patches/python-robotframework-ug2html.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-robotframework-ug2html.patch b/gnu/packages/patches/python-robotframework-ug2html.patch
new file mode 100644
index 0000000000..eea88e01f3
--- /dev/null
+++ b/gnu/packages/patches/python-robotframework-ug2html.patch
@@ -0,0 +1,57 @@
+Do not require the obsolete robotframeworklexer.
+
+Submitted upstream at: https://github.com/robotframework/robotframework/pull/4265.
+diff --git a/doc/userguide/ug2html.py b/doc/userguide/ug2html.py
+index 43cdb31bd..033203552 100755
+--- a/doc/userguide/ug2html.py
++++ b/doc/userguide/ug2html.py
+@@ -93,34 +93,26 @@ from docutils.parsers.rst import directives
+ from pygments import highlight, __version__ as pygments_version
+ from pygments.lexers import get_lexer_by_name
+ 
+-# Use latest version, not version bundled with Pygments
+-import robotframeworklexer
+-
+ 
+ def too_old(version_string, minimum):
+     version = tuple(int(v) for v in version_string.split('.')[:2])
+     return version < minimum
+ 
+ 
+-if too_old(getattr(robotframeworklexer, '__version__', '1.0'), (1, 1)):
+-    sys.exit('robotframeworklexer >= 1.1 is required.')
+-if too_old(pygments_version, (2, 1)):
+-    sys.exit('Pygments >= 2.1 is required.')
++if too_old(pygments_version, (2, 8)):
++    sys.exit('Pygments >= 2.8 is required.')
+ 
+ 
+ def pygments_directive(name, arguments, options, content, lineno,
+                        content_offset, block_text, state, state_machine):
+     try:
+-        if arguments[0] == 'robotframework':
+-            lexer = robotframeworklexer.RobotFrameworkLexer()
+-        else:
+-            lexer = get_lexer_by_name(arguments[0])
++        lexer = get_lexer_by_name(arguments[0])
+     except ValueError as err:
+         raise ValueError(f'Invalid syntax highlighting language "{arguments[0]}".')
+     # take an arbitrary option if more than one is given
+     formatter = options and VARIANTS[options.keys()[0]] or DEFAULT
+     # possibility to read the content from an external file
+-    filtered = [ line for line in content if line.strip() ]
++    filtered = [line for line in content if line.strip()]
+     if len(filtered) == 1:
+         path = filtered[0].replace('/', os.sep)
+         if os.path.isfile(path):
+diff --git a/requirements-build.txt b/requirements-build.txt
+index e0f5e19a2..a2fcdcfd5 100644
+--- a/requirements-build.txt
++++ b/requirements-build.txt
+@@ -5,5 +5,4 @@ rellu >= 0.7
+ twine >= 1.12
+ wheel
+ docutils
+-pygments >= 2.1
+-robotframeworklexer >= 1.1
++pygments >= 2.8