summary refs log tree commit diff
path: root/gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2014-11-17 19:36:01 -0600
committerEric Bavier <bavier@member.fsf.org>2014-12-02 08:33:31 -0600
commitb88e1b0a626aa434e3934732392140dc9e919dd6 (patch)
tree2f879006bb12bec7deb345bcc69b522f08c3ebb5 /gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch
parent7639105b1270dd8063c97e822276104595207211 (diff)
downloadguix-b88e1b0a626aa434e3934732392140dc9e919dd6.tar.gz
gnu: python: Add sqlite input.
* gnu/packages/patches/python-sqlite-3.8.4-test-fix.patch,
  gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch: New patches.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/python.scm (python-2)[source]: Add patch.
  [inputs]: Add sqlite.
  (python)[source]: Add patch.
Diffstat (limited to 'gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch')
-rw-r--r--gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch b/gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch
new file mode 100644
index 0000000000..f121e8852a
--- /dev/null
+++ b/gnu/packages/patches/python2-sqlite-3.8.4-test-fix.patch
@@ -0,0 +1,15 @@
+From resolution of upstream python issue #20901: http://bugs.python.org/issue20901
+
+diff --git a/Lib/sqlite3/test/hooks.py b/Lib/sqlite3/test/hooks.py
+--- Lib/sqlite3/test/hooks.py
++++ Lib/sqlite3/test/hooks.py
+@@ -162,7 +162,7 @@ class ProgressTests(unittest.TestCase):
+             create table bar (a, b)
+             """)
+         second_count = len(progress_calls)
+-        self.assertTrue(first_count > second_count)
++        self.assertGreaterEqual(first_count, second_count)
+ 
+     def CheckCancelOperation(self):
+         """
+