summary refs log tree commit diff
path: root/gnu/packages/patches/python2-subprocess32-disable-input-test.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-06 21:58:19 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-03-06 23:21:34 +0100
commit550bd98b41c2bf3bfdcf3da29a41f0933b102266 (patch)
tree7d966f4cc6356a04b6363601e29443a17a82c535 /gnu/packages/patches/python2-subprocess32-disable-input-test.patch
parent7ccb71e0ea95ae14e3b2698fe3be0738878fc93e (diff)
downloadguix-550bd98b41c2bf3bfdcf3da29a41f0933b102266.tar.gz
gnu: Add python2-subprocess32.
* gnu/packages/python.scm (python2-subprocess32): New variable.
* gnu/packages/patches/python2-subprocess32-disable-input-test.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/python2-subprocess32-disable-input-test.patch')
-rw-r--r--gnu/packages/patches/python2-subprocess32-disable-input-test.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/python2-subprocess32-disable-input-test.patch b/gnu/packages/patches/python2-subprocess32-disable-input-test.patch
new file mode 100644
index 0000000000..05b4eef1ba
--- /dev/null
+++ b/gnu/packages/patches/python2-subprocess32-disable-input-test.patch
@@ -0,0 +1,18 @@
+This test tries to send a KeyboardInterrupt, which does
+not work in the build environment.
+
+--- a/test_subprocess32.py	2017-03-06 22:21:49.334045485 +0100
++++ b/test_subprocess32.py	2017-03-06 22:22:02.490439949 +0100
+@@ -1299,12 +1299,6 @@
+         getattr(p, method)(*args)
+         return p
+ 
+-    def test_send_signal(self):
+-        p = self._kill_process('send_signal', signal.SIGINT)
+-        _, stderr = p.communicate()
+-        self.assertIn('KeyboardInterrupt', stderr)
+-        self.assertNotEqual(p.wait(), 0)
+-
+     def test_kill(self):
+         p = self._kill_process('kill')
+         _, stderr = p.communicate()