summary refs log tree commit diff
path: root/gnu/packages/patches/qemu-CVE-2016-2197.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-05-11 13:37:47 -0400
committerMark H Weaver <mhw@netris.org>2016-05-11 13:37:47 -0400
commit9f5e79675367aedd6be89e07edbc08a6e3695fab (patch)
tree2679dfc572b7173ba6fe52611047a47283af119d /gnu/packages/patches/qemu-CVE-2016-2197.patch
parente2b89203db6c2056c9658be40ab1be471769d9eb (diff)
parentcf60e76a9503156a8c1047fa446525b28842f7e8 (diff)
downloadguix-9f5e79675367aedd6be89e07edbc08a6e3695fab.tar.gz
Merge branch 'master' into gnome-updates
Diffstat (limited to 'gnu/packages/patches/qemu-CVE-2016-2197.patch')
-rw-r--r--gnu/packages/patches/qemu-CVE-2016-2197.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/patches/qemu-CVE-2016-2197.patch b/gnu/packages/patches/qemu-CVE-2016-2197.patch
deleted file mode 100644
index d851e1ec75..0000000000
--- a/gnu/packages/patches/qemu-CVE-2016-2197.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From: John Snow <jsnow@redhat.com>
-Date: Wed, 10 Feb 2016 13:29:40 -0500
-Subject: [PATCH] ahci: Do not unmap NULL addresses
-
-Definitely don't try to unmap a garbage address.
-
-Reported-by: Zuozhi fzz <zuozhi.fzz@alibaba-inc.com>
-Signed-off-by: John Snow <jsnow@redhat.com>
-Message-id: 1454103689-13042-2-git-send-email-jsnow@redhat.com
-(cherry picked from commit 99b4cb71069f109b79b27bc629fc0cf0886dbc4b)
----
- hw/ide/ahci.c | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/hw/ide/ahci.c b/hw/ide/ahci.c
-index 17f1cbd..cdc9299 100644
---- a/hw/ide/ahci.c
-+++ b/hw/ide/ahci.c
-@@ -661,6 +661,10 @@ static bool ahci_map_fis_address(AHCIDevice *ad)
- 
- static void ahci_unmap_fis_address(AHCIDevice *ad)
- {
-+    if (ad->res_fis == NULL) {
-+        DPRINTF(ad->port_no, "Attempt to unmap NULL FIS address\n");
-+        return;
-+    }
-     dma_memory_unmap(ad->hba->as, ad->res_fis, 256,
-                      DMA_DIRECTION_FROM_DEVICE, 256);
-     ad->res_fis = NULL;
-@@ -677,6 +681,10 @@ static bool ahci_map_clb_address(AHCIDevice *ad)
- 
- static void ahci_unmap_clb_address(AHCIDevice *ad)
- {
-+    if (ad->lst == NULL) {
-+        DPRINTF(ad->port_no, "Attempt to unmap NULL CLB address\n");
-+        return;
-+    }
-     dma_memory_unmap(ad->hba->as, ad->lst, 1024,
-                      DMA_DIRECTION_FROM_DEVICE, 1024);
-     ad->lst = NULL;