summary refs log tree commit diff
path: root/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-10-14 20:52:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-10-15 17:19:27 +0200
commit1007640a63de6749a93e94a2751f66af56b01d07 (patch)
tree2bb80ee12174e58cfffa7398d74fc9bc7e73dbae /gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch
parent8fcba3be282b4df60eec99338e5afee061d87242 (diff)
downloadguix-1007640a63de6749a93e94a2751f66af56b01d07.tar.gz
gnu: ruby-concurrent: Update to 1.1.5.
* gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch,
gnu/packages/patches/ruby-concurrent-test-arm.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/ruby.scm (ruby-concurrent): Update to 1.1.5.
[source](patches): Remove.
[arguments]: Set #:test-target to "ci".  Remove obsolete phases.  Remove
dependencies on 'rake_compiler_dock' and concurrent_ruby.jar.
Diffstat (limited to 'gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch')
-rw-r--r--gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch16
1 files changed, 0 insertions, 16 deletions
diff --git a/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch b/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch
deleted file mode 100644
index 4e801c3225..0000000000
--- a/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-This test appears to fail in GNU Guix and elsewhere.  It has been reported
-upstream at https://github.com/puma/puma/issues/995
-
-diff --git a/spec/concurrent/channel_spec.rb b/spec/concurrent/channel_spec.rb
-index d70fba8..4f29a8b 100644
---- a/spec/concurrent/channel_spec.rb
-+++ b/spec/concurrent/channel_spec.rb
-@@ -598,7 +598,7 @@ module Concurrent
-           }.to raise_error(ArgumentError)
-         end
- 
--        it 'loops until the block returns false' do
-+        xit 'loops until the block returns false' do
-           actual = 0
-           expected = 3
-           latch = Concurrent::CountDownLatch.new(expected)