summary refs log tree commit diff
path: root/gnu/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-06-12 22:02:04 -0400
committerLeo Famulari <leo@famulari.name>2016-06-12 22:09:26 -0400
commitee86e7e14859533045e1f7727ae731ba6ba72daf (patch)
treea5f51a9c4859a3242b46876797b98e77a5a7506e /gnu/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch
parent8af5cac527eee03005f3809578a0d8258a878f95 (diff)
parentfe585be9aa8f5158a7dfb6477d19ece3d643dec3 (diff)
downloadguix-ee86e7e14859533045e1f7727ae731ba6ba72daf.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch')
-rw-r--r--gnu/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch b/gnu/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch
new file mode 100644
index 0000000000..5d1f04b994
--- /dev/null
+++ b/gnu/packages/patches/ruby-tzinfo-data-ignore-broken-test.patch
@@ -0,0 +1,13 @@
+diff --git a/test/tc_definitions.rb b/test/tc_definitions.rb
+index 7b20a3d..75b9798 100644
+--- a/test/tc_definitions.rb
++++ b/test/tc_definitions.rb
+@@ -58,7 +58,7 @@ class TCDefinitions < Minitest::Test
+         identifier = $3.to_sym
+         is_dst = $4 == '1'
+  
+-        if utc && local
++        if utc && local && !line.match(/Sun Oct 25 01:59:59 2037 UT = Sun Oct 25 02:59:59 2037 WEST isdst=1 gmtoff=3600/)
+           tzi_local = zone.utc_to_local(utc)
+           tzi_period = zone.period_for_utc(utc)
+           tzi_identifier = tzi_period.zone_identifier