summary refs log tree commit diff
path: root/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-23 21:45:21 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-03-23 21:45:21 -0400
commit839bb4616f13171a23ad7937bf57d0a01d61d42a (patch)
tree01de78a5ce973b9fb7ac0f9216d64f736f8e163d /gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch
parent0357bbbcd850f9220078a62da3c30358b8983765 (diff)
parentef71e3290916583973724316e815cee840c1b6d8 (diff)
downloadguix-839bb4616f13171a23ad7937bf57d0a01d61d42a.tar.gz
Merge remote-tracking branch 'origin/master' into staging.
With resolved conflicts in:
	gnu/packages/ibus.scm
	gnu/packages/image.scm
	gnu/packages/lisp.scm
	gnu/packages/virtualization.scm
Diffstat (limited to 'gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch')
-rw-r--r--gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch b/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch
new file mode 100644
index 0000000000..ccc9c09fb9
--- /dev/null
+++ b/gnu/packages/patches/sbcl-eazy-gnuplot-skip-path-check.patch
@@ -0,0 +1,14 @@
+Don't check whether gnuplot is present in $PATH, because we know it is.
+
+diff --git a/eazy-gnuplot.asd b/eazy-gnuplot.asd
+index 7b1c09b..4657cd6 100644
+--- a/eazy-gnuplot.asd
++++ b/eazy-gnuplot.asd
+@@ -37,7 +37,4 @@
+                                :fill-pointer t)))
+           (setf (fill-pointer seq) (read-sequence seq stream))
+           seq)))
+-  :perform (load-op :before (op c)
+-                    (unless (zerop (nth-value 2 (uiop:run-program "which gnuplot" :ignore-error-status t)))
+-                      (warn "Could not find GNUPLOT in $PATH")))
+   :in-order-to ((test-op (test-op eazy-gnuplot.test))))