summary refs log tree commit diff
path: root/gnu/packages/patches/torsocks-dns-test.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-11-10 18:38:04 +0100
committerLudovic Courtès <ludo@gnu.org>2015-11-11 00:37:50 +0100
commitba583bd2ce887cdd8b99ea55c15b57c5209e4b58 (patch)
tree8fb9c09eda0cb5acbe080ee55b766b716a15c149 /gnu/packages/patches/torsocks-dns-test.patch
parent68d85de16383d054dbf4fb5da2437f9cc743e5d2 (diff)
downloadguix-ba583bd2ce887cdd8b99ea55c15b57c5209e4b58.tar.gz
gnu: torsocks: Upgrade to 2.0.0.
* gnu/packages/tor.scm (torsocks): Update to 2.0.0.
  [source]: Fetch from git.torproject.org.  Use
  'torsocks-dns-test.patch'.
  [arguments, native-inputs]: New fields.
  [license]: Change to GPL2.
* gnu/packages/patches/torsocks-dns-test.patch: New file.
* gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches/torsocks-dns-test.patch')
-rw-r--r--gnu/packages/patches/torsocks-dns-test.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/patches/torsocks-dns-test.patch b/gnu/packages/patches/torsocks-dns-test.patch
new file mode 100644
index 0000000000..ba70ba5933
--- /dev/null
+++ b/gnu/packages/patches/torsocks-dns-test.patch
@@ -0,0 +1,18 @@
+Skip DNS tests that rely on the ability to look up arbitary
+host names.
+
+--- torsocks/tests/test_dns.c	2015-11-10 18:30:53.955941984 +0100
++++ torsocks/tests/test_dns.c	2015-11-10 18:31:02.199941892 +0100
+@@ -134,11 +134,8 @@ static void test_getaddrinfo(const struc
+ int main(int argc, char **argv)
+ {
+ 	/* Libtap call for the number of tests planned. */
+-	plan_tests(NUM_TESTS);
++	plan_tests(1);
+ 
+-	test_getaddrinfo(&tor_check);
+-    test_gethostbyname(&tor_dir_auth1);
+-	test_gethostbyaddr(&tor_dir_auth2);
+ 	test_getaddrinfo(&tor_localhost);
+ 
+     return 0;