summary refs log tree commit diff
path: root/gnu/packages/patches/tvtime-xmltv.patch
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2015-04-28 22:21:37 +0300
committerAlex Kost <alezost@gmail.com>2015-05-10 18:30:54 +0300
commit6633f86b4941ec35bb4c328ec1e0b2bbfc41ad83 (patch)
tree09e0eda652523a63580ef0cc779b142101e4d24c /gnu/packages/patches/tvtime-xmltv.patch
parentf0b98b848384f2957a1658a73f0ff20bcec38c23 (diff)
downloadguix-6633f86b4941ec35bb4c328ec1e0b2bbfc41ad83.tar.gz
gnu: Add tvtime.
* gnu/packages/tv.scm,
  gnu/packages/patches/tvtime-gcc41.patch,
  gnu/packages/patches/tvtime-pngoutput.patch,
  gnu/packages/patches/tvtime-videodev2.patch,
  gnu/packages/patches/tvtime-xmltv.patch: New files.
* gnu-system.am (GNU_SYSTEM_MODULES): Add package.
  (dist_patch_DATA): Add patches.
Diffstat (limited to 'gnu/packages/patches/tvtime-xmltv.patch')
-rw-r--r--gnu/packages/patches/tvtime-xmltv.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/patches/tvtime-xmltv.patch b/gnu/packages/patches/tvtime-xmltv.patch
new file mode 100644
index 0000000000..2f4afc6e5a
--- /dev/null
+++ b/gnu/packages/patches/tvtime-xmltv.patch
@@ -0,0 +1,28 @@
+Fix compilation error: conflicting types for 'locale_t'.
+
+This is an excerpt from the debian patch ... 
+http://http.debian.net/debian/pool/main/t/tvtime/tvtime_1.0.2-14.diff.gz
+
+--- tvtime-1.0.2.orig/src/xmltv.c
++++ tvtime-1.0.2/src/xmltv.c
+@@ -118,9 +118,9 @@
+ typedef struct {
+     const char *code;
+     const char *name;
+-} locale_t;
++} tvtime_locale_t;
+ 
+-static locale_t locale_table[] = {
++static tvtime_locale_t locale_table[] = {
+     {"AA", "Afar"},           {"AB", "Abkhazian"},      {"AF", "Afrikaans"},
+     {"AM", "Amharic"},        {"AR", "Arabic"},         {"AS", "Assamese"},
+     {"AY", "Aymara"},         {"AZ", "Azerbaijani"},    {"BA", "Bashkir"},
+@@ -168,7 +168,7 @@
+     {"XH", "Xhosa"},          {"YO", "Yoruba"},         {"ZH", "Chinese"},
+     {"ZU", "Zulu"} };
+ 
+-const int num_locales = sizeof( locale_table ) / sizeof( locale_t );
++const int num_locales = sizeof( locale_table ) / sizeof( tvtime_locale_t );
+ 
+ /**
+  * Timezone parsing code based loosely on the algorithm in