summary refs log tree commit diff
path: root/gnu/packages/patches/unzip-CVE-2014-8140.patch
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-30 14:46:21 -0500
committerMark H Weaver <mhw@netris.org>2014-12-30 14:48:13 -0500
commite5da2f38c3ca8d4626c1b87e045d00d28c1bf4d0 (patch)
treee033809b82b840dc259b7d1a430cf32edb17b02a /gnu/packages/patches/unzip-CVE-2014-8140.patch
parentc7bdc7ece5650be75314dc302f3cdcf02806857b (diff)
downloadguix-e5da2f38c3ca8d4626c1b87e045d00d28c1bf4d0.tar.gz
gnu: unzip: Add fixes for CVE-2014-{8139,8140,8141}.
* gnu/packages/patches/unzip-CVE-2014-8139.patch,
  gnu/packages/patches/unzip-CVE-2014-8140.patch,
  gnu/packages/patches/unzip-CVE-2014-8141.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/zip.scm (unzip): Add patches.
Diffstat (limited to 'gnu/packages/patches/unzip-CVE-2014-8140.patch')
-rw-r--r--gnu/packages/patches/unzip-CVE-2014-8140.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/unzip-CVE-2014-8140.patch b/gnu/packages/patches/unzip-CVE-2014-8140.patch
new file mode 100644
index 0000000000..595d8d5bcd
--- /dev/null
+++ b/gnu/packages/patches/unzip-CVE-2014-8140.patch
@@ -0,0 +1,27 @@
+From: sms
+Subject: Fix CVE-2014-8140: out-of-bounds write issue in test_compr_eb()
+Bug-Debian: http://bugs.debian.org/773722
+
+--- a/extract.c
++++ b/extract.c
+@@ -2234,10 +2234,17 @@
+     if (compr_offset < 4)                /* field is not compressed: */
+         return PK_OK;                    /* do nothing and signal OK */
+ 
++    /* Return no/bad-data error status if any problem is found:
++     *    1. eb_size is too small to hold the uncompressed size
++     *       (eb_ucsize).  (Else extract eb_ucsize.)
++     *    2. eb_ucsize is zero (invalid).  2014-12-04 SMS.
++     *    3. eb_ucsize is positive, but eb_size is too small to hold
++     *       the compressed data header.
++     */
+     if ((eb_size < (EB_UCSIZE_P + 4)) ||
+-        ((eb_ucsize = makelong(eb+(EB_HEADSIZE+EB_UCSIZE_P))) > 0L &&
+-         eb_size <= (compr_offset + EB_CMPRHEADLEN)))
+-        return IZ_EF_TRUNC;               /* no compressed data! */
++     ((eb_ucsize = makelong( eb+ (EB_HEADSIZE+ EB_UCSIZE_P))) == 0L) ||
++     ((eb_ucsize > 0L) && (eb_size <= (compr_offset + EB_CMPRHEADLEN))))
++        return IZ_EF_TRUNC;             /* no/bad compressed data! */
+ 
+     if (
+ #ifdef INT_16BIT