summary refs log tree commit diff
path: root/gnu/packages/patches/util-linux-tests.patch
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-23 14:19:02 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-23 16:29:19 +0100
commit9f533d60df8c248c790c41d80653e693e1a3f9e5 (patch)
tree1b9c26ace24c4acb58e0dd02775db4ed26871245 /gnu/packages/patches/util-linux-tests.patch
parent61bce2f9cb1abc0221a843c4f77384d1532ffa55 (diff)
downloadguix-9f533d60df8c248c790c41d80653e693e1a3f9e5.tar.gz
gnu: util-linux: Update to 2.25.2.
* gnu/packages/linux.scm (util-linux): Update to 2.25.2.  Remove
  util-linux-perl.patch, and add util-linux-tests.patch.  Adjust
  'snippet'.
  [arguments]: Remove 'patch-chkdupexe' phase.  Add 'pre-check' phase.
  [native-inputs]: Add NET-BASE.
* gnu/packages/patches/util-linux-perl.patch: Remove.
* gnu/packages/patches/util-linux-tests.patch: New file.
* gnu-system.am (dist_patch_DATA): Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/util-linux-tests.patch')
-rw-r--r--gnu/packages/patches/util-linux-tests.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/patches/util-linux-tests.patch b/gnu/packages/patches/util-linux-tests.patch
new file mode 100644
index 0000000000..2ad025f66a
--- /dev/null
+++ b/gnu/packages/patches/util-linux-tests.patch
@@ -0,0 +1,30 @@
+This test checks whether 'root' is successfully translated to UID/GID 0,
+using 'getpwnam' in libmount.  This doesn't work in the chroot because
+/etc/passwd doesn't contain an entry for 'root' so skip it.
+
+
+--- util-linux-2.25.2/tests/ts/libmount/optstr	2015-01-23 13:58:41.181151194 +0100
++++ util-linux-2.25.2/tests/ts/libmount/optstr	2015-01-23 13:58:42.829161716 +0100
+@@ -84,10 +84,6 @@ ts_init_subtest "apply-user"	# add user,
+ ts_valgrind $TESTPROG --apply --user "noexec,nosuid,loop=/dev/looop0" 0x408 &> $TS_OUTPUT
+ ts_finalize_subtest
+ 
+-ts_init_subtest "fix"
+-ts_valgrind $TESTPROG --fix "uid=root,gid=root" &> $TS_OUTPUT
+-ts_finalize_subtest
+-
+ ts_init_subtest "deduplicate"
+ ts_valgrind $TESTPROG --dedup bbb,ccc,AAA,xxx,AAA=a,AAA=bbb,ddd,AAA=ccc,fff=eee AAA &> $TS_OUTPUT
+ ts_finalize_subtest
+
+
+The expected output for this test seems to lack a carriage return.
+
+--- util-linux-2.25.2/tests/expected/more/regexp	2015-01-23 14:02:21.098557632 +0100
++++ util-linux-2.25.2/tests/expected/more/regexp	2015-01-23 14:02:23.598573648 +0100
+@@ -1,4 +1,4 @@
+ 
+ ...skipping
+-foo
++
foo
+ xyzzy