summary refs log tree commit diff
path: root/gnu/packages/patches/wicd-bitrate-none-fix.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 23:50:26 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:53:42 -0400
commitedac21bfc78ffea85f4dac7206e5e7cd621bba19 (patch)
tree6985981ed25a3a9807c59a1b5b040d76feaeb0a7 /gnu/packages/patches/wicd-bitrate-none-fix.patch
parentbbbfe095fb167cb56b1fd9a20bf50bf53a0cdaf5 (diff)
downloadguix-edac21bfc78ffea85f4dac7206e5e7cd621bba19.tar.gz
gnu: Remove wicd.
The last release is from 2017, stuck on Python 2.

* gnu/packages/wicd.scm: Delete file.
* gnu/packages/patches/wicd-bitrate-none-fix.patch: Delete file.
* gnu/packages/patches/wicd-get-selected-profile-fix.patch: Likewise.
* gnu/packages/patches/wicd-urwid-1.3.patch: Likewise.
* gnu/packages/patches/wicd-wpa2-ttls.patch: Likewise.
* gnu/local.mk: De-register them.
* gnu/services/networking.scm: Remove wicd service...
* doc/guix.texi: ... and its documentation.
* gnu/system/linux-container.scm (containerized-operating-system)
<services-to-drop>: Remove wicd-service-type.
Diffstat (limited to 'gnu/packages/patches/wicd-bitrate-none-fix.patch')
-rw-r--r--gnu/packages/patches/wicd-bitrate-none-fix.patch24
1 files changed, 0 insertions, 24 deletions
diff --git a/gnu/packages/patches/wicd-bitrate-none-fix.patch b/gnu/packages/patches/wicd-bitrate-none-fix.patch
deleted file mode 100644
index 1809b7217d..0000000000
--- a/gnu/packages/patches/wicd-bitrate-none-fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Fix copied from https://bugs.launchpad.net/wicd/+bug/1432423/comments/1
-
---- wicd-1.7.3/curses/netentry_curses.py	1969-12-31 19:00:00.000000000 -0500
-+++ wicd-1.7.3/curses/netentry_curses.py	2015-08-11 23:26:19.999999649 -0400
-@@ -538,11 +538,16 @@
-         self.bitrates = wireless.GetAvailableBitrates()
-         self.bitrates.append('auto')
-         self.bitrate_combo.set_list(self.bitrates)
-+
-+        # bitrate property is sometimes None
-+        chosen_bitrate = wireless.GetWirelessProperty(networkID, 'bitrate')
-+        if chosen_bitrate not in self.bitrates:
-+            chosen_bitrate = 'auto'
-+
-         self.bitrate_combo.set_focus(
--            self.bitrates.index(
--                wireless.GetWirelessProperty(networkID, 'bitrate')
--            )
-+            self.bitrates.index(chosen_bitrate)
-         )
-+
-         self.allow_lower_bitrates_chkbox.set_state(
-             to_bool(self.format_entry(networkID, 'allow_lower_bitrates'))
-         )