summary refs log tree commit diff
path: root/gnu/packages/patches/xpra-4.2-install_libs.patch
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-25 22:07:13 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-01-25 22:07:13 -0500
commit1a5302435ff0d2822b823f5a6fe01faa7a85c629 (patch)
treeac7810c88b560532f22d2bab2e59609cd7305c21 /gnu/packages/patches/xpra-4.2-install_libs.patch
parent3ff2ac4980dacf10087e4b42bd9fbc490591900c (diff)
parent070b8a893febd6e7d8b2b7c8c4dcebacf7845aa9 (diff)
downloadguix-1a5302435ff0d2822b823f5a6fe01faa7a85c629.tar.gz
Merge branch 'master' into staging.
With "conflicts" solved (all in favor of master except git) in:
	gnu/local.mk
	gnu/packages/databases.scm
	gnu/packages/glib.scm
	gnu/packages/gnome.scm
	gnu/packages/gnupg.scm
	gnu/packages/gnuzilla.scm
	gnu/packages/graphics.scm
	gnu/packages/gstreamer.scm
	gnu/packages/gtk.scm
	gnu/packages/linux.scm
	gnu/packages/machine-learning.scm
	gnu/packages/networking.scm
	gnu/packages/polkit.scm
	gnu/packages/pulseaudio.scm
	gnu/packages/rpc.scm
	gnu/packages/rust.scm
	gnu/packages/version-control.scm
	gnu/packages/w3m.scm
Diffstat (limited to 'gnu/packages/patches/xpra-4.2-install_libs.patch')
-rw-r--r--gnu/packages/patches/xpra-4.2-install_libs.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/patches/xpra-4.2-install_libs.patch b/gnu/packages/patches/xpra-4.2-install_libs.patch
new file mode 100644
index 0000000000..65d489a3b8
--- /dev/null
+++ b/gnu/packages/patches/xpra-4.2-install_libs.patch
@@ -0,0 +1,29 @@
+This workaround for Gentoo interferes with our use of --no-compile during
+the 'install stage.
+
+--- a/setup.py	2022-01-04 10:10:05.039825000 +0100
++++ b/setup.py	2022-01-06 15:10:31.952656039 +0100
+@@ -589,8 +589,6 @@
+         })
+ 
+ def add_cython_ext(*args, **kwargs):
+-    if "--no-compile" in sys.argv and not ("build" in sys.argv and "install" in sys.argv):
+-        return
+     assert cython_ENABLED, "cython compilation is disabled"
+     if cython_tracing_ENABLED:
+         kwargs["define_macros"] = [
+@@ -1703,14 +1701,6 @@
+             if uinput_ENABLED:
+                 add_data_files("lib/udev/rules.d/", ["fs/lib/udev/rules.d/71-xpra-virtual-pointer.rules"])
+ 
+-    #gentoo does weird things, calls --no-compile with build *and* install
+-    #then expects to find the cython modules!? ie:
+-    #> python2.7 setup.py build -b build-2.7 install --no-compile \
+-    # --root=/var/tmp/portage/x11-wm/xpra-0.7.0/temp/images/2.7
+-    #otherwise we use the flags to skip pkgconfig
+-    if ("--no-compile" in sys.argv or "--skip-build" in sys.argv) and not ("build" in sys.argv and "install" in sys.argv):
+-        pkgconfig = no_pkgconfig
+-
+     if OSX and "py2app" in sys.argv:
+         import py2app    #@UnresolvedImport
+         assert py2app is not None